]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta: convert nested overrides leftovers to new syntax
authorDenys Dmytriyenko <denis@denix.org>
Wed, 4 Aug 2021 01:28:04 +0000 (21:28 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 4 Aug 2021 19:41:45 +0000 (20:41 +0100)
Those were missed in previous rounds of automated and manual conversion.

Signed-off-by: Denys Dmytriyenko <denis@denix.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/manpages.bbclass
meta/recipes-devtools/gcc/gcc-configure-common.inc
meta/recipes-devtools/gcc/gcc-cross-canadian.inc
meta/recipes-devtools/gcc/gcc-runtime.inc
meta/recipes-devtools/gdb/gdb-common.inc
meta/recipes-kernel/perf/perf.bb

index 3a966594600574f5f2efeb941bc2169f20da5f90..64b7d8c42226089371127bc6b6c506e45fb040d6 100644 (file)
@@ -12,7 +12,7 @@ MAN_PKG ?= "${PN}-doc"
 # only add man-db to RDEPENDS when manual files are built and installed
 RDEPENDS:${MAN_PKG} += "${@bb.utils.contains('PACKAGECONFIG', 'manpages', 'man-db', '', d)}"
 
-pkg_postinst:append_${MAN_PKG} () {
+pkg_postinst:append:${MAN_PKG} () {
        # only update manual page index caches when manual files are built and installed
        if ${@bb.utils.contains('PACKAGECONFIG', 'manpages', 'true', 'false', d)}; then
                if test -n "$D"; then
@@ -36,7 +36,7 @@ pkg_postinst:append_${MAN_PKG} () {
        fi
 }
 
-pkg_postrm:append_${MAN_PKG} () {
+pkg_postrm:append:${MAN_PKG} () {
        # only update manual page index caches when manual files are built and installed
        if ${@bb.utils.contains('PACKAGECONFIG', 'manpages', 'true', 'false', d)}; then
                mandb -q
index e9bc8e466c073b16695e0641afc3f7a410d71c42..e4cdb73f0a4557324043796cbd56834d6e6fd008 100644 (file)
@@ -56,7 +56,7 @@ export gcc_cv_collect2_libs = 'none required'
 # in the config.log files (which might not get generated until do_compile
 # hence being missed by the insane do_configure check).
 
-EXTRA_OECONF:append_linux = " --enable-__cxa_atexit"
+EXTRA_OECONF:append:linux = " --enable-__cxa_atexit"
 
 EXTRA_OECONF:append:mips64 = " --with-abi=64 --with-arch-64=mips64 --with-tune-64=mips64"
 EXTRA_OECONF:append:mips64el = " --with-abi=64 --with-arch-64=mips64 --with-tune-64=mips64"
index 92fb1f38ba3feaf9266e8911333036881308b110..495dd9070b10af77f079a7d4647e0a674e7d1d3e 100644 (file)
@@ -180,9 +180,9 @@ SYSTEMLIBS = "${target_base_libdir}/"
 SYSTEMLIBS1 = "${target_libdir}/"
 
 EXTRA_OECONF += "--enable-poison-system-directories"
-EXTRA_OECONF:remove_elf = "--with-sysroot=/not/exist"
-EXTRA_OECONF:remove_eabi = "--with-sysroot=/not/exist"
-EXTRA_OECONF:append_elf = " --without-headers --with-newlib"
-EXTRA_OECONF:append_eabi = " --without-headers --with-newlib"
+EXTRA_OECONF:remove:elf = "--with-sysroot=/not/exist"
+EXTRA_OECONF:remove:eabi = "--with-sysroot=/not/exist"
+EXTRA_OECONF:append:elf = " --without-headers --with-newlib"
+EXTRA_OECONF:append:eabi = " --without-headers --with-newlib"
 # gcc 4.7 needs -isystem
 export ARCH_FLAGS_FOR_TARGET = "--sysroot=${STAGING_DIR_TARGET} -isystem=${target_includedir}"
index 9e39d49d14e7c2666c0470663f7aeb2747318327..4839a6687afd2989f94d3e62a67e69973f899d38 100644 (file)
@@ -281,7 +281,7 @@ SUMMARY:libitm-staticdev = "GNU transactional memory support library - static de
 
 require gcc-testsuite.inc
 
-EXTRA_OEMAKE:prepend_task-check = "${PARALLEL_MAKE} "
+EXTRA_OEMAKE:prepend:task-check = "${PARALLEL_MAKE} "
 
 MAKE_CHECK_TARGETS ??= "check-gcc ${@" ".join("check-target-" + i for i in d.getVar("RUNTIMETARGET").split())}"
 # prettyprinters and xmethods require gdb tooling
index 01cca123f8b66f41e20eda3c547780f6f4cf9e04..0fe7b4e5b06e99f96452ac40dca487d3cbcb7874 100644 (file)
@@ -59,7 +59,7 @@ do_install:append() {
        rm -f ${D}${infodir}/bfd.info
 }
 
-RRECOMMENDS:gdb:append_linux = " glibc-thread-db "
-RRECOMMENDS:gdb:append_linux-gnueabi = " glibc-thread-db "
-RRECOMMENDS:gdbserver:append_linux = " glibc-thread-db "
-RRECOMMENDS:gdbserver:append_linux-gnueabi = " glibc-thread-db "
+RRECOMMENDS:gdb:append:linux = " glibc-thread-db "
+RRECOMMENDS:gdb:append:linux-gnueabi = " glibc-thread-db "
+RRECOMMENDS:gdbserver:append:linux = " glibc-thread-db "
+RRECOMMENDS:gdbserver:append:linux-gnueabi = " glibc-thread-db "
index 8ebd7d7cb526392765507650e57e2e66528f7ba3..f473272096fc123fd08ffa51d02ae30ef32b5b51 100644 (file)
@@ -110,7 +110,7 @@ EXTRA_OEMAKE += "\
 # that it has to be done this way rather than by passing -j1, since
 # perf's build system by default ignores any -j argument, but does
 # honour a JOBS variable.
-EXTRA_OEMAKE:append_task-configure = " JOBS=1"
+EXTRA_OEMAKE:append:task-configure = " JOBS=1"
 
 PERF_SRC ?= "Makefile \
              tools/arch \