]> code.ossystems Code Review - openembedded-core.git/commitdiff
curl: fix https certificate problems
authorKoen Kooi <koen.kooi@linaro.org>
Tue, 11 Feb 2014 09:54:54 +0000 (10:54 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 11 Feb 2014 17:15:48 +0000 (17:15 +0000)
point CA bundle to /etc/ssl/certs/ca-certificates.crt instead of using the buildhost location, Configure would look at the buildhost and hardcode the bundle location for there into the target. This leads to non-working https support.

Also remove the empty and now useless curl-certs packages since it's empty and no ALLOW_EMPTY has been set.

Apart from making https work again with curl cmdline this also fixes libcurl which means git can fetch https repos as well instead of erroring out.

Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/curl/curl_7.34.0.bb

index b49c6e442a0cb22ec46c4231882ba17dcb1d5b97..aba6649a669921ea5d129b6669094e4712bc0a54 100644 (file)
@@ -30,6 +30,7 @@ EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
                 --enable-crypto-auth \
                 --disable-ldap \
                 --disable-ldaps \
+                --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
                 ${CURLGNUTLS} \
                 "
 
@@ -45,13 +46,10 @@ do_install_append() {
        oe_multilib_header curl/curlbuild.h
 }
 
-PACKAGES =+ "${PN}-certs libcurl libcurl-dev libcurl-staticdev libcurl-doc"
-
-FILES_${PN}-certs = "${datadir}/curl/curl-*"
-PACKAGE_ARCH_${PN}-certs = "all"
+PACKAGES =+ "libcurl libcurl-dev libcurl-staticdev libcurl-doc"
 
 FILES_lib${BPN} = "${libdir}/lib*.so.*"
-RRECOMMENDS_lib${BPN} += "${PN}-certs"
+RRECOMMENDS_lib${BPN} += "ca-certificates"
 FILES_lib${BPN}-dev = "${includedir} \
                       ${libdir}/lib*.so \
                       ${libdir}/lib*.la \