]> code.ossystems Code Review - openembedded-core.git/commitdiff
insane.class: print the recipe name in the warning.
authorNitin A Kamble <nitin.a.kamble@intel.com>
Tue, 13 Jul 2010 16:41:25 +0000 (09:41 -0700)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 15 Jul 2010 12:46:06 +0000 (13:46 +0100)
Now Warning includes the package name like zlib is printed bellow:

WARNING: zlib: Recipe file does not have license file information
(LIC_FILES_CHKSUM)

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
meta/classes/insane.bbclass

index 6b14f9002706357670ab7ef89d1a35c8f9299805..b7ab98d34ff6eb7b1d1156cf5bae1875c2e6b387 100644 (file)
@@ -343,11 +343,12 @@ def package_qa_check_license(workdir, d):
     sane = True
 
     lic_files = bb.data.getVar('LIC_FILES_CHKSUM', d, True)
+    pn = bb.data.getVar('PN', d, True)
 
     if not lic_files:
         # just throw a warning now. Once licensing data in entered for enough of the recipes,
         # this will be converted into error and False will be returned.
-        bb.warn(" Recipe (.bb) file does not have license file information (LIC_FILES_CHKSUM)")
+        bb.warn(pn + ": Recipe file does not have license file information (LIC_FILES_CHKSUM)")
         return True
 
     srcdir = bb.data.getVar('S', d, True)