]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/3.14: fix qemumips build error
authorBruce Ashfield <bruce.ashfield@windriver.com>
Fri, 6 Feb 2015 21:03:25 +0000 (16:03 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 8 Feb 2015 08:00:04 +0000 (08:00 +0000)
The merge of the 3.14 -stable series triggered a build failure in the
32 bit mips builds.

Updating the SRCREVs to import the fix for the issue.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
meta/recipes-kernel/linux/linux-yocto_3.14.bb

index 342debe2c93029970069280ae6195b574c036263..8e2189654bc5084fc55726d6da490168e56a8a40 100644 (file)
@@ -3,8 +3,8 @@ KBRANCH_qemuppc ?= "standard/preempt-rt/qemuppc"
 
 require recipes-kernel/linux/linux-yocto.inc
 
-SRCREV_machine ?= "c9291eb73e9729480c651cca73babdb29e193ad4"
-SRCREV_machine_qemuppc ?= "35bfb41271634b66522164efeb424822993899c7"
+SRCREV_machine ?= "fbe20225d041672b110e93c3ad171737b69e2126"
+SRCREV_machine_qemuppc ?= "11f38e2b2a63c5b1138617c197b3f5b96cd74a65"
 SRCREV_meta ?= "6eddbf47875ef48ddc5864957a7b63363100782b"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.14.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
index 0808d1bf1a23cf6c38ebb4a1e32c5713381250ea..db9ad738c3ab1664d2d31beb1ab84465ee2e66ce 100644 (file)
@@ -8,7 +8,7 @@ LINUX_VERSION ?= "3.14.29"
 
 KMETA = "meta"
 
-SRCREV_machine ?= "1e0bbd1dd68e255a9af7c36930debc6dd4885d0c"
+SRCREV_machine ?= "f65678ef48c5d41af914d2769e4dd01411c1df96"
 SRCREV_meta ?= "6eddbf47875ef48ddc5864957a7b63363100782b"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
index 19b7c126bada282419eca5bf45370997b35ab8ec..ac0143089795965d64593ddf8f3f40ebeb277d11 100644 (file)
@@ -11,14 +11,14 @@ KBRANCH_qemux86  ?= "standard/common-pc/base"
 KBRANCH_qemux86-64 ?= "standard/common-pc-64/base"
 KBRANCH_qemumips64 ?= "standard/mti-malta64"
 
-SRCREV_machine_qemuarm ?= "4af8557eb8576ba957980705a3719aca0e27836e"
-SRCREV_machine_qemuarm64 ?= "1e0bbd1dd68e255a9af7c36930debc6dd4885d0c"
-SRCREV_machine_qemumips ?= "520d5d89434c61b4a95ac0c68d8e74fc8068e35b"
-SRCREV_machine_qemuppc ?= "73e4399fd8db810cb59423767f9ca82a54311c7b"
-SRCREV_machine_qemux86 ?= "19e871b55f80d4cbd406b64d3d5fabf6103e6f1c"
-SRCREV_machine_qemux86-64 ?= "1e0bbd1dd68e255a9af7c36930debc6dd4885d0c"
-SRCREV_machine_qemumips64 ?= "6a469761ad8b3a0e585e53b842ea8d55d05089e3"
-SRCREV_machine ?= "1e0bbd1dd68e255a9af7c36930debc6dd4885d0c"
+SRCREV_machine_qemuarm ?= "1a9f9edade8d8c0120d2f47dfd15edd41c7a3439"
+SRCREV_machine_qemuarm64 ?= "f65678ef48c5d41af914d2769e4dd01411c1df96"
+SRCREV_machine_qemumips ?= "68e9a20079f3cc333c3b7d945bb65fa74772aa37"
+SRCREV_machine_qemuppc ?= "a992646d267f012f87967f1c8b88608c950c7e58"
+SRCREV_machine_qemux86 ?= "2f37d969c5d3b28d936ac3533862e2ab034d4f37"
+SRCREV_machine_qemux86-64 ?= "f65678ef48c5d41af914d2769e4dd01411c1df96"
+SRCREV_machine_qemumips64 ?= "e93012684a290e9b60d61f58c2dbd36ab3f2e549"
+SRCREV_machine ?= "f65678ef48c5d41af914d2769e4dd01411c1df96"
 SRCREV_meta ?= "6eddbf47875ef48ddc5864957a7b63363100782b"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.14.git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"