]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3: Substitute correct python version in shebang
authorTyler Hall <tylerwhall@gmail.com>
Sun, 4 May 2014 22:37:50 +0000 (18:37 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 8 May 2014 11:56:40 +0000 (12:56 +0100)
If python2 and python3 are both available, scripts that are subject to
this substitution can possibly run with the wrong python version.
python3-config is one such script.

Signed-off-by: Tyler Hall <tylerwhall@gmail.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/python/python3-native_3.3.3.bb

index 7238eaf27d98436e72b40b52848ddfd29217d485..0fd73498e85ee73897c098c00c954ee5ff3a2368 100644 (file)
@@ -71,6 +71,6 @@ do_install() {
 
        # Make sure we use /usr/bin/env python
        for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
-               sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT
+               sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
        done
 }