]> code.ossystems Code Review - openembedded-core.git/commitdiff
bitbake-bblayers/create: Make the example recipe print its message
authorYoann Congal <yoann.congal@smile.fr>
Fri, 9 Oct 2020 07:15:45 +0000 (09:15 +0200)
committerSteve Sakoman <steve@sakoman.com>
Mon, 19 Oct 2020 14:27:15 +0000 (04:27 -1000)
The example recipe is setup to print a message using bb.plain() in the
"do_build" task but this task is "noexec" so the message never prints.
This might be confusing.

This moves the message printing into another "do_display_banner" task
and add it to the do_build "before" list.

Signed-off-by: Yoann Congal <yoann.congal@smile.fr>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 252385bef9b226f32691b8513869ea3e41813b40)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/lib/bblayers/templates/example.bb

index c4b873d593cc5167ccea1bb71dca4dd06094def7..facaae35d23ada89791f13c58faf8a6e56cb1ed1 100644 (file)
@@ -2,10 +2,12 @@ SUMMARY = "bitbake-layers recipe"
 DESCRIPTION = "Recipe created by bitbake-layers"
 LICENSE = "MIT"
 
-python do_build() {
+python do_display_banner() {
     bb.plain("***********************************************");
     bb.plain("*                                             *");
     bb.plain("*  Example recipe created by bitbake-layers   *");
     bb.plain("*                                             *");
     bb.plain("***********************************************");
 }
+
+addtask display_banner before do_build