]> code.ossystems Code Review - openembedded-core.git/commitdiff
openjade-native: Run make depend to ensure dependencies are correct and avoid paralle...
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 16 Mar 2011 17:12:00 +0000 (17:12 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 16 Mar 2011 17:36:36 +0000 (17:36 +0000)
[YOCTO #877]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/openjade/openjade-native_1.3.2.bb

index e8a7c4513a547bfbf1abc80b047799ab492558ff..0de8b963ab2614bab30f9967d8d6a4d712241c23 100644 (file)
@@ -31,6 +31,12 @@ CFLAGS =+ "-I${S}/include"
 
 SSTATEPOSTINSTFUNCS += "openjade_sstate_postinst"
 
+# We need to do this else the source interdependencies aren't generated and
+# build failures can result (e.g. zero size style/Makefile.dep file)
+do_compile_prepend () {
+       oe_runmake depend
+}
+
 do_install() {
        # Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/openjade.html
        # for details.