]> code.ossystems Code Review - openembedded-core.git/commitdiff
m4-native: Fix building on Ubuntu 9.10
authorEsben Haabendal <esbenhaabendal@gmail.com>
Tue, 10 Nov 2009 12:20:59 +0000 (13:20 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 10 Nov 2009 12:54:58 +0000 (12:54 +0000)
Avoid making GNUmakefile a symlink to itself with some versions
of autoconf/automake

Signed-off-by: Esben Haabendal <eha@doredevelopment.dk>
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/m4/m4-native_1.4.12.bb
meta/packages/m4/m4/ac_config_links.patch [new file with mode: 0644]

index 64442292e001a95403c8522e57d5ef722f5ccb0f..74fa3c865a0ca21c8df88a170d8c288fcaac8e02 100644 (file)
@@ -1,6 +1,10 @@
 require m4_${PV}.bb
 inherit native
 
+PR = "r1"
+
+SRC_URI_append = " file://ac_config_links.patch;patch=1"
+
 INHIBIT_AUTOTOOLS_DEPS = "1"
 DEPENDS += "gnu-config-native"
 
diff --git a/meta/packages/m4/m4/ac_config_links.patch b/meta/packages/m4/m4/ac_config_links.patch
new file mode 100644 (file)
index 0000000..2210387
--- /dev/null
@@ -0,0 +1,28 @@
+This patch fixes a build problem for m4-native experienced on Ubuntu 9.10,
+where autoconf/automake (AC_CONFIG_LINKS) ends up making GNUmakefile a
+symlink to itself.
+
+The patch comments out ac_config_links directly in configure,
+as autoreconf is not actually run for m4-native.
+
+I believe it should be safe, as GNUmakefile is actually unpacked from
+source, and what we want is to is to not touch it.
+
+Tested on x86_64_linux (Ubuntu 8.04 and 9.10).
+
+2009-11-10     Esben Haabendal     <eha@doredevelopment.dk>
+
+diff -urN m4-1.4.13.orig/configure m4-1.4.13/configure
+--- m4-1.4.13.orig/configure   2009-11-10 10:54:00.301707097 +0100
++++ m4-1.4.13/configure        2009-11-10 10:54:17.314206379 +0100
+@@ -14860,8 +14860,8 @@
+   # only, it does not matter if we skip the link with older autoconf.
+   # Automake 1.10.1 and earlier try to remove GNUmakefile in non-VPATH
+   # builds, so use a shell variable to bypass this.
+-  GNUmakefile=GNUmakefile
+-  ac_config_links="$ac_config_links $GNUmakefile:$GNUmakefile"
++ # GNUmakefile=GNUmakefile
++ # ac_config_links="$ac_config_links $GNUmakefile:$GNUmakefile"