]> code.ossystems Code Review - openembedded-core.git/commitdiff
rootfs_ipk.bbclass, package-index: With the fixed ipkg-utils there is no need to...
authorRichard Purdie <richard@openedhand.com>
Mon, 24 Jul 2006 08:27:13 +0000 (08:27 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 24 Jul 2006 08:27:13 +0000 (08:27 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@545 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/classes/rootfs_ipk.bbclass
meta/packages/meta/package-index.bb

index 27295035076e63431307171868d0408526a6451f..8dfba10b5eb10a8db948d6795614fd24162a9c7c 100644 (file)
@@ -31,8 +31,6 @@ real_do_rootfs () {
        mkdir -p ${IMAGE_ROOTFS}/dev
 
        if [ -z "${DEPLOY_KEEP_PACKAGES}" ]; then
-               rm -f ${DEPLOY_DIR_IPK}/Packages
-               touch ${DEPLOY_DIR_IPK}/Packages
                ipkg-make-index -r ${DEPLOY_DIR_IPK}/Packages -p ${DEPLOY_DIR_IPK}/Packages -l ${DEPLOY_DIR_IPK}/Packages.filelist -m ${DEPLOY_DIR_IPK}
        fi
        mkdir -p ${T}
index f230af0e271a8842609f27ff4b754956ec61de45..0f8c450e3745b85f192f659897e17386e3f20589 100644 (file)
@@ -27,8 +27,6 @@ do_build[nostamp] = 1
 do_build[dirs] = "${DEPLOY_DIR_IPK}"
 do_build() {
        set -ex
-       rm -f Packages
-       touch Packages
        ipkg-make-index -r Packages -p Packages -l Packages.filelist -m .
        set +ex
 }