]> code.ossystems Code Review - openembedded-core.git/commitdiff
[#BUG298]:Fix some bugs during compiling based on x86_64
authorXiaofeng Yan <xiaofeng.yan@windriver.com>
Tue, 21 Sep 2010 08:32:13 +0000 (16:32 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 21 Sep 2010 23:03:00 +0000 (00:03 +0100)
fix a problem that compliation failed for groff on machine x86_64
Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com>
meta/recipes-extended/groff/groff_1.18.1.4.bb

index a215745ce400aeffb6f977bee3313c452d45bc40..b78cbfa02da02151bf7e6a22f7dcb8cb6b0efa6b 100644 (file)
@@ -3,44 +3,39 @@ SECTION = "console/utils"
 PRIORITY = "required"
 HOMEPAGE = "ftp://ftp.gnu.org/gnu/groff/"
 LICENSE = "GPLv2"
-PR = "r0"
+PR = "r1"
 
 LIC_FILE_CHKSUM = "file://CORYING;md5=e43fc16fccd8519fba405f0a0ff6e8a3"
 
-SRC_URI = "ftp://ftp.gnu.org/gnu/groff/groff-1.18.1.4.tar.gz \
+SRC_URI = "ftp://ftp.gnu.org/gnu/groff/groff-${PV}.tar.gz \
           file://groff-1.18.1.4-remove-mom.patch;striplevel=1 \
-          file://man-local.patch;patch=1 \
-          file://mdoc-local.patch;patch=1
+          file://man-local.patch \
+          file://mdoc-local.patch" 
 
 inherit autotools
 
-EXTRA_OEMAKE =+ "-f Makefile mandir=${D}${mandir}"
+EXTRA_OECONF="--without-x --prefix=${D} --exec-prefix=${D} --bindir=${D}${bindir} --datadir=${D}${datadir} --mandir=${D}${datadir}/man --infodir=${D}${datadir}info --with-appresdir=${D}${datadir}"
+PARALLEL_MAKE = ""
+
 
-localdir=/usr/local/
 do_configure (){
-       mkdir -p ${D}/usr/local  
-        ${S}/configure --prefix=${D}/usr/local
+       oe_runconf
 }
 
-
-fakeroot do_install(){
-        mkdir -p ${D}/usr/local/man/man1
-        mkdir -p ${D}/usr/local/man/man5
-        mkdir -p ${D}/usr/local/man/man7
-        oe_runmake install DESTDIR=${D}
+do_install_prepend() {
+  install -m 0755 -d ${D}
 }
 
+
 do_install_append() {
-    mv ${D}/usr/local/bin ${D}/usr
-    mkdir -p ${D}${sysconfdir}/groff
-    cp -rf ${D}/usr/local/share/groff/site-tmac/* ${D}/usr/local/share/groff/1.18.1.4/tmac/
-    cp -rf ${D}/usr/local/share/groff/site-tmac/* ${D}${sysconfdir}/groff/
+     mkdir -p ${D}${sysconfdir}/groff
+     cp -rf ${D}${datadir}/groff/site-tmac/* ${D}${sysconfdir}/groff/
+     cp -rf ${D}${datadir}/groff/site-tmac/* ${D}${datadir}/groff/${PV}/tmac/
 }
 
 pkg_postinst_${PN}() {
     ln -s ${bindir}/tbl ${bindir}/gtbl
-   echo "export GROFF_FONT_PATH=/usr/local/share/groff/1.18.1.4/font" >> ${sysconfdir}/profile
-    echo "export GROFF_TMAC_PATH=/usr/local/share/groff/1.18.1.4/tmac" >> ${sysconfdir}/profile
+    echo "export GROFF_FONT_PATH=/usr/share/groff/${PV}/font" >> ${sysconfdir}/profile
+    echo "export GROFF_TMAC_PATH=/usr/share/groff/${PV}/tmac" >> ${sysconfdir}/profile
 }
 
-FILES_${PN} += "${localdir}/"