]> code.ossystems Code Review - openembedded-core.git/commitdiff
moblin-proto: update srcrev and fix build
authorRoss Burton <ross@openedhand.com>
Mon, 18 Aug 2008 14:18:37 +0000 (14:18 +0000)
committerRoss Burton <ross@openedhand.com>
Mon, 18 Aug 2008 14:18:37 +0000 (14:18 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5070 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/conf/distro/include/poky-fixed-revisions.inc
meta/packages/clutter/moblin-proto/fix.patch
meta/packages/clutter/moblin-proto/paths.patch [new file with mode: 0644]
meta/packages/clutter/moblin-proto_git.bb

index 31eecb8e49092eb092f0df2e9675d9c70c8f5b18..4c0e503491a02fb9f22b2c3c22b89db6d28ffa67 100644 (file)
@@ -88,7 +88,7 @@ SRCREV_pn-libopensync-plugin-evo2-sync ?= "2394"
 SRCREV_pn-libopensync-plugin-file-sync ?= "2392"
 SRCREV_pn-libopensync ?= "2430"
 SRCREV_pn-libsync ?= "208"
-SRCREV_pn-moblin-proto ?= "5905975caaac3dd3206b35db5b36b75c44d6a0df"
+SRCREV_pn-moblin-proto ?= "8f2cb524fe06555182c25b4ba3202d7b368ac0ce"
 SRCREV_pn-msynctool ?= "314"
 SRCREV_pn-networkmanager-applet ?= "263"
 SRCREV_pn-networkmanager ?= "2984"
index 802b8c4b6c4f1165444aa625d12ce018991a2744..8bde67762c9087cf9788f02df5db6cca2624bc8b 100644 (file)
@@ -20,25 +20,3 @@ Index: git/Makefile
  
  #$(BINARY): $(CFILES)
  #     $(LD) $(CFLAGS) $(INCS) $(CFILES) $(LIBS) -o $@
-Index: git/moblin-desktop.c
-===================================================================
---- git.orig/moblin-desktop.c  2008-08-11 22:49:49.000000000 +0100
-+++ git/moblin-desktop.c       2008-08-12 12:14:44.000000000 +0100
-@@ -620,17 +620,10 @@
-   attach_reactivate_on_press (old_app);
--<<<<<<< HEAD:moblin-desktop.c
-   shuttle = clutter_group_new ();
-   clutter_group_add (CLUTTER_GROUP(desktop->mainstuff), shuttle);
-   copy_geometry (desktop->middle, shuttle);
-   clutter_actor_reparent (old_app, shuttle);
--=======
--  box = clutter_group_new ();
--  clutter_group_add (CLUTTER_GROUP(desktop->stage), box);
--  copy_geometry (desktop->middle, box);
--  clutter_actor_reparent (old_app, box);
-->>>>>>> Removed now unneeded forcible shows of apps.:moblin-desktop.c
-   {
-     gint    x, y;
diff --git a/meta/packages/clutter/moblin-proto/paths.patch b/meta/packages/clutter/moblin-proto/paths.patch
new file mode 100644 (file)
index 0000000..d241c8f
--- /dev/null
@@ -0,0 +1,15 @@
+diff --git a/moblin-desktop.h b/moblin-desktop.h
+index 880a9ad..3d51a14 100644
+--- a/moblin-desktop.h
++++ b/moblin-desktop.h
+@@ -29,8 +29,8 @@
+ #define __MAIN_H__
+-#define ASSET_ROOT "./assets/"
+-#define JSON_ROOT "./layouts/"
++#define ASSET_ROOT "/usr/share/moblin-proto/assets/"
++#define JSON_ROOT "/usr/share/moblin-proto/layouts/"
+ typedef struct
+ {
index 00b5b5e3f3ed212c98b46addbe19478f54a83f74..8ce97bbeabd5fad148132289d76248afc4f55d50 100644 (file)
@@ -1,14 +1,18 @@
-
 DEPENDS = "clutter-box2d"
 
 PV = "0.0+git${SRCREV}"
+PR = "r1"
 
 SRC_URI = "git://moblin.org/repos/users/pippin/prototype.git/;protocol=http \
-           file://fix.patch;patch=1"
+           file://paths.patch;patch=1"
 
 S = "${WORKDIR}/git"
 
 do_install () {
        install -d ${D}${bindir}
        install ${S}/moblin-proto ${D}${bindir}
+
+       install -d ${D}${datadir}/moblin-proto/
+        cp -a ${S}/assets ${D}${datadir}/moblin-proto/
+        cp -a ${S}/layouts ${D}${datadir}/moblin-proto/
 }