]> code.ossystems Code Review - openembedded-core.git/commitdiff
xkeyboard-config: Inherit gettext
authorAndrei Gherzan <andrei@gherzan.ro>
Fri, 7 Nov 2014 16:23:44 +0000 (17:23 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 20 Nov 2014 14:06:27 +0000 (14:06 +0000)
In a GPLv3-free build we have two different versions of gettext in sysroot due
to GPLv3 restrictions. In this case we need gettext-native too so we can have
the needed macros and avoid errors like:
"error: possibly undefined macro: AM_GNU_GETTEXT"

The needed dependency is added by gettext class which is prefered because it
takes care of NLS flags too.

Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-graphics/xorg-lib/xkeyboard-config_2.12.bb

index 61e38470c1c032eab9d7649e0262b64cccbd6e26..adac0eedd8eb6e813f17fe03504774e1b39273c4 100644 (file)
@@ -23,7 +23,7 @@ EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps"
 
 FILES_${PN} += "${datadir}/X11/xkb"
 
-inherit autotools pkgconfig
+inherit autotools pkgconfig gettext
 
 do_install_append () {
     install -d ${D}${datadir}/X11/xkb/compiled