]> code.ossystems Code Review - openembedded-core.git/commitdiff
freetype: Update EXTRA_OECONF to use host gcc.
authorNoor Ahsan <noor_ahsan@mentor.com>
Thu, 20 Dec 2012 11:37:24 +0000 (16:37 +0500)
committerSaul Wold <sgw@linux.intel.com>
Tue, 25 Dec 2012 22:00:20 +0000 (14:00 -0800)
* It uses host gcc in its configure script. When IA32
toolchain is installed it starts using its binaries instead
of native gcc. Modified EXTRA_OECONF so that host gcc is used.

Signed-off-by: Noor Ahsa <noor_ahsan@mentor.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-graphics/freetype/freetype_2.4.10.bb

index 9365475bcca27b427dae4639b31641420017f31b..35d6d221f313f5bd8d4ad95a39e56f2b4baba947 100644 (file)
@@ -28,7 +28,7 @@ inherit autotools pkgconfig binconfig
 LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
 EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
 EXTRA_OEMAKE_class-native = ""
-EXTRA_OECONF = "--without-zlib --without-bzip2"
+EXTRA_OECONF = "--without-zlib --without-bzip2 CC_BUILD='${BUILD_CC}'"
 
 do_configure() {
        cd builds/unix