]> code.ossystems Code Review - openembedded-core.git/commitdiff
e2fsprogs: use update-alt for chattr
authorSaul Wold <sgw@linux.intel.com>
Fri, 13 Jun 2014 17:40:21 +0000 (10:40 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 14 Jun 2014 07:41:42 +0000 (08:41 +0100)
Both busybox and e2fsprogs provide chattr, ensure that they are delivered
to the same location and use update-alternatives to ensure the correct
links are there.

[YOCTO #6407]

Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.9.bb

index 2bdd7246a200877f5bacdeb770565241444688d7..530255474db894c9fee99d462adebc5d5619aeb2 100644 (file)
@@ -54,6 +54,8 @@ do_install () {
        fi
 
        oe_multilib_header ext2fs/ext2_types.h
+       install -d ${D}${base_bindir}
+       mv ${D}${bindir}/chattr ${D}${base_bindir}/chattr.e2fsprogs
 }
 
 RDEPENDS_e2fsprogs = "e2fsprogs-badblocks"
@@ -73,3 +75,10 @@ FILES_libext2fs = "${libdir}/e2initrd_helper ${base_libdir}/libext2fs.so.*"
 FILES_${PN}-dev += "${datadir}/*/*.awk ${datadir}/*/*.sed ${base_libdir}/*.so"
 
 BBCLASSEXTEND = "native"
+
+inherit update-alternatives
+
+ALTERNATIVE_${PN} = "chattr"
+ALTERNATIVE_PRIORITY = "100"
+ALTERNATIVE_LINK_NAME[chattr] = "${base_bindir}/chattr"
+ALTERNATIVE_TARGET[chattr] = "${base_bindir}/chattr.e2fsprogs"