]> code.ossystems Code Review - openembedded-core.git/commitdiff
coreutils: add forgotten patches for 5.3.0
authorMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 25 Apr 2007 13:23:09 +0000 (13:23 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 25 Apr 2007 13:23:09 +0000 (13:23 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1558 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/coreutils/coreutils-5.3.0/install-cross.patch [new file with mode: 0644]
meta/packages/coreutils/coreutils-5.3.0/man.patch [new file with mode: 0644]
meta/packages/coreutils/coreutils-5.3.0/rename-tee-for-glibc2.5.patch [new file with mode: 0644]
meta/packages/coreutils/coreutils-5.3.0/uptime-pow-lib.patch [new file with mode: 0644]

diff --git a/meta/packages/coreutils/coreutils-5.3.0/install-cross.patch b/meta/packages/coreutils/coreutils-5.3.0/install-cross.patch
new file mode 100644 (file)
index 0000000..98ba3d9
--- /dev/null
@@ -0,0 +1,27 @@
+--- src/install.c~     2003-08-09 18:46:45.000000000 +0100
++++ src/install.c      2004-03-27 18:38:45.000000000 +0000
+@@ -516,7 +516,14 @@
+ strip (const char *path)
+ {
+   int status;
+-  pid_t pid = fork ();
++  pid_t pid;
++  char *strip_name;
++
++  strip_name = getenv ("STRIP");
++  if (strip_name == NULL)
++    strip_name = "strip";
++
++  pid = fork ();
+   switch (pid)
+     {
+@@ -524,7 +531,7 @@
+       error (EXIT_FAILURE, errno, _("fork system call failed"));
+       break;
+     case 0:                   /* Child. */
+-      execlp ("strip", "strip", path, NULL);
++      execlp (strip_name, "strip", path, NULL);
+       error (EXIT_FAILURE, errno, _("cannot run strip"));
+       break;
+     default:                  /* Parent. */
diff --git a/meta/packages/coreutils/coreutils-5.3.0/man.patch b/meta/packages/coreutils/coreutils-5.3.0/man.patch
new file mode 100644 (file)
index 0000000..5060e4f
--- /dev/null
@@ -0,0 +1,42 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- coreutils-5.3.0/configure.ac~man
++++ coreutils-5.3.0/configure.ac
+@@ -237,6 +237,20 @@
+ AM_GNU_GETTEXT([external], [need-ngettext])
+ AM_GNU_GETTEXT_VERSION(0.13.1)
++AC_MSG_CHECKING([whether to build man pages])
++AC_ARG_WITH(manpages, 
++      AS_HELP_STRING([--with-manpages],
++              [Enable building of manpages (default=yes)]),
++      [cu_cv_build_manpages=$enableval],
++      [cu_cv_build_manpages=yes])
++# help2man doesn't work when crosscompiling, as it needs to run the
++# binary that was built.
++if test x"$cross_compiling" = x"yes"; then
++  cu_cv_build_manpages=no
++fi
++AC_MSG_RESULT($cu_cv_build_manpages)
++AM_CONDITIONAL(ENABLE_MANPAGES, test x"$cu_cv_build_manpages" = x"yes")
++
+ AC_CONFIG_FILES(
+   Makefile
+   doc/Makefile
+--- coreutils-5.3.0/Makefile.am~man
++++ coreutils-5.3.0/Makefile.am
+@@ -1,6 +1,11 @@
+ ## Process this file with automake to produce Makefile.in -*-Makefile-*-
++if ENABLE_MANPAGES
+ SUBDIRS = lib src doc man po tests
++else
++SUBDIRS = lib src doc po tests
++endif
++
+ EXTRA_DIST = Makefile.cfg Makefile.maint GNUmakefile \
+   .kludge-stamp .prev-version THANKS-to-translators THANKStt.in \
+   .x-sc_space_tab .x-sc_sun_os_names \
diff --git a/meta/packages/coreutils/coreutils-5.3.0/rename-tee-for-glibc2.5.patch b/meta/packages/coreutils/coreutils-5.3.0/rename-tee-for-glibc2.5.patch
new file mode 100644 (file)
index 0000000..148a5f4
--- /dev/null
@@ -0,0 +1,33 @@
+Glibc 2.5 has a function called tee which conflicts with the same function
+in coreutils. This patch renames the function to tee_files (as is done in
+the newer coreutils versions.)
+
+--- coreutils-5.3.0/src/tee.c  2006/10/23 07:35:00     1.1
++++ coreutils-5.3.0/src/tee.c  2006/10/23 07:35:16
+@@ -31,7 +31,7 @@
+ #define AUTHORS "Mike Parker", "Richard M. Stallman", "David MacKenzie"
+-static bool tee (int nfiles, const char **files);
++static bool tee_files (int nfiles, const char **files);
+ /* If true, append to output files rather than truncating them. */
+ static bool append;
+@@ -121,7 +121,7 @@
+   /* Do *not* warn if tee is given no file arguments.
+      POSIX requires that it work when given no arguments.  */
+-  ok = tee (argc - optind, (const char **) &argv[optind]);
++  ok = tee_files (argc - optind, (const char **) &argv[optind]);
+   if (close (STDIN_FILENO) != 0)
+     error (EXIT_FAILURE, errno, _("standard input"));
+@@ -133,7 +133,7 @@
+    Return true if successful.  */
+ static bool
+-tee (int nfiles, const char **files)
++tee_files (int nfiles, const char **files)
+ {
+   FILE **descriptors;
+   char buffer[BUFSIZ];
diff --git a/meta/packages/coreutils/coreutils-5.3.0/uptime-pow-lib.patch b/meta/packages/coreutils/coreutils-5.3.0/uptime-pow-lib.patch
new file mode 100644 (file)
index 0000000..5eb3fca
--- /dev/null
@@ -0,0 +1,11 @@
+--- coreutils-5.3.0/src/Makefile.am.orig       2005-09-27 22:34:35.659272058 -0700
++++ coreutils-5.3.0/src/Makefile.am    2005-09-27 22:34:39.403507668 -0700
+@@ -74,7 +74,7 @@
+ sleep_LDADD = $(nanosec_libs)
+ tail_LDADD = $(nanosec_libs)
+-uptime_LDADD = $(LDADD) $(GETLOADAVG_LIBS)
++uptime_LDADD = $(LDADD) $(POW_LIB) $(GETLOADAVG_LIBS)
+ su_LDADD = $(LDADD) $(LIB_CRYPT)