]> code.ossystems Code Review - openembedded-core.git/commitdiff
xorg: replace depricated *proto depends with xorgproto
authorArmin Kuster <akuster@mvista.com>
Wed, 4 Apr 2018 01:49:19 +0000 (18:49 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 2 May 2018 13:05:23 +0000 (14:05 +0100)
Signed-off-by: Armin Kuster <akuster@mvista.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
42 files changed:
meta/recipes-graphics/mesa/mesa.inc
meta/recipes-graphics/xorg-app/mkfontscale_1.1.3.bb
meta/recipes-graphics/xorg-app/rgb_1.0.6.bb
meta/recipes-graphics/xorg-app/xev_1.2.2.bb
meta/recipes-graphics/xorg-driver/xf86-video-intel_git.bb
meta/recipes-graphics/xorg-driver/xf86-video-omap_0.4.5.bb
meta/recipes-graphics/xorg-driver/xf86-video-vesa_2.4.0.bb
meta/recipes-graphics/xorg-driver/xf86-video-vmware_13.2.1.bb
meta/recipes-graphics/xorg-driver/xorg-driver-common.inc
meta/recipes-graphics/xorg-driver/xorg-driver-input.inc
meta/recipes-graphics/xorg-driver/xorg-driver-video.inc
meta/recipes-graphics/xorg-lib/libdmx_1.1.3.bb
meta/recipes-graphics/xorg-lib/libfontenc_1.1.3.bb
meta/recipes-graphics/xorg-lib/libice_1.0.9.bb
meta/recipes-graphics/xorg-lib/libsm_1.2.2.bb
meta/recipes-graphics/xorg-lib/libx11.inc
meta/recipes-graphics/xorg-lib/libxau_1.0.8.bb
meta/recipes-graphics/xorg-lib/libxcalibrate_git.bb
meta/recipes-graphics/xorg-lib/libxcb_1.13.bb
meta/recipes-graphics/xorg-lib/libxcomposite_0.4.4.bb
meta/recipes-graphics/xorg-lib/libxdamage_1.1.4.bb
meta/recipes-graphics/xorg-lib/libxdmcp_1.1.2.bb
meta/recipes-graphics/xorg-lib/libxext_1.3.3.bb
meta/recipes-graphics/xorg-lib/libxfixes_5.0.3.bb
meta/recipes-graphics/xorg-lib/libxfont2_2.0.3.bb
meta/recipes-graphics/xorg-lib/libxfont_1.5.4.bb
meta/recipes-graphics/xorg-lib/libxi_1.7.9.bb
meta/recipes-graphics/xorg-lib/libxinerama_1.1.3.bb
meta/recipes-graphics/xorg-lib/libxkbfile_1.0.9.bb
meta/recipes-graphics/xorg-lib/libxrandr_1.5.1.bb
meta/recipes-graphics/xorg-lib/libxrender_0.9.10.bb
meta/recipes-graphics/xorg-lib/libxres_1.2.0.bb
meta/recipes-graphics/xorg-lib/libxscrnsaver_1.2.2.bb
meta/recipes-graphics/xorg-lib/libxt_1.1.5.bb
meta/recipes-graphics/xorg-lib/libxtst_1.2.3.bb
meta/recipes-graphics/xorg-lib/libxv_1.0.11.bb
meta/recipes-graphics/xorg-lib/libxvmc_1.0.10.bb
meta/recipes-graphics/xorg-lib/libxxf86dga_1.1.4.bb
meta/recipes-graphics/xorg-lib/libxxf86misc_1.0.3.bb
meta/recipes-graphics/xorg-lib/libxxf86vm_1.1.4.bb
meta/recipes-graphics/xorg-util/makedepend_1.0.5.bb
meta/recipes-graphics/xorg-xserver/xserver-xorg.inc

index b501b7e726ddd1075518fef86cc45a3b11f80db3..5660f44a3be5653378986cf038f1d297dd7d9e4a 100644 (file)
@@ -47,7 +47,7 @@ PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland vulkan', d)} \
 # "gbm" requires "dri", "opengl"
 PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm"
 
-X11_DEPS = "xf86driproto glproto virtual/libx11 libxext libxxf86vm libxdamage libxfixes"
+X11_DEPS = "xorgproto virtual/libx11 libxext libxxf86vm libxdamage libxfixes"
 # "x11" requires "opengl"
 PACKAGECONFIG[x11] = "--enable-glx-tls,--disable-glx,${X11_DEPS}"
 PACKAGECONFIG[xvmc] = "--enable-xvmc,--disable-xvmc,libxvmc"
@@ -57,8 +57,8 @@ DRIDRIVERS = "swrast"
 DRIDRIVERS_append_x86 = ",radeon,r200,nouveau,i965,i915"
 DRIDRIVERS_append_x86-64 = ",radeon,r200,nouveau,i965,i915"
 # "dri" requires "opengl"
-PACKAGECONFIG[dri] = "--enable-dri --with-dri-drivers=${DRIDRIVERS}, --disable-dri, dri2proto libdrm"
-PACKAGECONFIG[dri3] = "--enable-dri3, --disable-dri3, dri3proto presentproto libxshmfence"
+PACKAGECONFIG[dri] = "--enable-dri --with-dri-drivers=${DRIDRIVERS}, --disable-dri, xorgproto libdrm"
+PACKAGECONFIG[dri3] = "--enable-dri3, --disable-dri3, xorgproto libxshmfence"
 
 # Vulkan drivers need dri3 enabled
 # radeon could be enabled as well but requires gallium-llvm with llvm >= 3.9
index 88c88f135e4d753e5e507e20dc55eef2847ce5e5..2a6bec16491e5034fa7915274f70673b46216f47 100644 (file)
@@ -8,7 +8,7 @@ font name (XLFD) is generated, and is written together with the file \
 name to a file fonts.scale in the directory.  The resulting fonts.scale \
 is used by the mkfontdir program."
 
-DEPENDS = "util-macros-native zlib libfontenc freetype xproto"
+DEPENDS = "util-macros-native zlib libfontenc freetype xorgproto"
 
 BBCLASSEXTEND = "native"
 
index 87268046e6de7311f4436cfe5ae8427be3f55bc6..c3e853631b924143866cab62ee9396af16825b04 100644 (file)
@@ -6,7 +6,7 @@ to RGB values (rgb.txt) and, if configured to use a database for color \
 lookup, the rgb program to convert the text file into the binary database \
 format."
 
-DEPENDS += " xproto util-macros"
+DEPENDS += " xorgproto util-macros"
 LIC_FILES_CHKSUM = "file://COPYING;md5=ef598adbe241bd0b0b9113831f6e249a"
 PE = "1"
 
index f151b579e31a789a23b59b6950a7bb916e809be1..0705b7f7f1946ae03dd5a5a61bbb1b36300fdc28 100644 (file)
@@ -10,7 +10,7 @@ LICENSE = "MIT"
 
 PE = "1"
 
-DEPENDS += "libxrandr xproto"
+DEPENDS += "libxrandr xorgproto"
 
 SRC_URI += "file://diet-x11.patch"
 
index 2623cb2f317601198e52340ebbb482df93e4fb07..893f5ce3f6458490575ed0f1742e2dd3b07ccb59 100644 (file)
@@ -28,9 +28,9 @@ DEPENDS += "virtual/libx11 drm libpciaccess pixman"
 PACKAGECONFIG ??= "xvmc uxa udev ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'dri dri1 dri2', '', d)}"
 
 PACKAGECONFIG[dri] = "--enable-dri,--disable-dri"
-PACKAGECONFIG[dri1] = "--enable-dri1,--disable-dri1,xf86driproto"
-PACKAGECONFIG[dri2] = "--enable-dri2,--disable-dri2,dri2proto"
-PACKAGECONFIG[dri3] = "--enable-dri3,--disable-dri3,dri3proto"
+PACKAGECONFIG[dri1] = "--enable-dri1,--disable-dri1,xorgproto"
+PACKAGECONFIG[dri2] = "--enable-dri2,--disable-dri2,xorgproto"
+PACKAGECONFIG[dri3] = "--enable-dri3,--disable-dri3,xorgproto"
 PACKAGECONFIG[sna] = "--enable-sna,--disable-sna"
 PACKAGECONFIG[uxa] = "--enable-uxa,--disable-uxa"
 PACKAGECONFIG[udev] = "--enable-udev,--disable-udev,udev"
index bef3636092127acba727a92b96c4f9565a76d597..0430f67b40eb11fef57bba556d71f3b845c9ce94 100644 (file)
@@ -22,7 +22,7 @@ omapdrm kernel driver w/ GEM support. \
 
 LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=10ce5de3b111315ea652a5f74ec0c602"
-DEPENDS += "virtual/libx11 libdrm xf86driproto"
+DEPENDS += "virtual/libx11 libdrm xorgproto"
 
 SRC_URI[md5sum] = "3b8ea5e8fba63355c0dc6681c49d5fe5"
 SRC_URI[sha256sum] = "93e7d42107521e61f61980eaea64fb452e87b7b94272e48938ac8d904ccfab5a"
index 5c1356de55c43d3d39535a44e31f4743b223cf60..9a110148d8130e262c5a7b470323116bb1d3329c 100644 (file)
@@ -9,7 +9,7 @@ can drive most VESA-compatible video cards, but only makes use of the \
 basic standard VESA core that is common to these cards. The driver \
 supports depths 8, 15 16 and 24."
 
-DEPENDS += "virtual/libx11 randrproto libpciaccess"
+DEPENDS += "virtual/libx11 xorgproto libpciaccess"
 
 COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
 
index 706d35d2fcd859266a8afca31c58e313ffa0cb08..0b63bbc67cc4ae3f8596e1ad146c1efdfca49dac 100644 (file)
@@ -6,7 +6,7 @@ DESCRIPTION = "vmware is an Xorg driver for VMware virtual video cards."
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=5fcd7d437a959a15fbee8707747c6b53"
 
-DEPENDS += "virtual/libx11 xineramaproto videoproto libpciaccess"
+DEPENDS += "virtual/libx11 xorgproto libpciaccess"
 
 SRC_URI += "file://0002-add-option-for-vmwgfx.patch"
 
index bca0aade6cb5ac8a8a912bb512d41e894632ec8d..e657c65b4ca6928dfa478d785d04c09f4df5a0bc 100644 (file)
@@ -7,7 +7,7 @@ LICENSE = "MIT-X"
 PE = "2"
 INC_PR = "r21"
 
-DEPENDS = "virtual/xserver xproto randrproto util-macros"
+DEPENDS = "virtual/xserver xorgproto util-macros"
 
 SRC_URI = "${XORG_MIRROR}/individual/driver/${BPN}-${PV}.tar.bz2"
 
index 342067d6c1c91a3b539ba19ca11c80b22a569bc5..57912e70dbeb8f0aaca788362def690115f491aa 100644 (file)
@@ -1,6 +1,6 @@
 require xorg-driver-common.inc
 
-DEPENDS += "inputproto kbproto "
+DEPENDS += "xorgproto"
 
 python add_xorg_abi_depends() {
     _add_xorg_abi_depends(d, "input")
index b5862dae1035f13c59d86c5032154395b4e83f71..2938ef11616bd5f307d5a7dbba4b8cded310f5f5 100644 (file)
@@ -1,6 +1,6 @@
 require xorg-driver-common.inc
 
-DEPENDS =+ "renderproto videoproto xextproto fontsproto"
+DEPENDS =+ "xorgproto"
 
 python add_xorg_abi_depends() {
     _add_xorg_abi_depends(d, "video")
index e623cee421b2bd613735e5975068056d074b9e8d..c74b706953024c9ee8f44880adfebfc61af36f32 100644 (file)
@@ -11,7 +11,7 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=a3c3499231a8035efd0e004cfbd3b72a \
                     file://src/dmx.c;endline=33;md5=c43f19af03c7c8619cadc9724ed9afe1"
 
-DEPENDS += "libxext dmxproto"
+DEPENDS += "libxext xorgproto"
 
 PE = "1"
 
index a181f05c29b26d6950343302581dd95b881753a6..34d5fc44874830b003740528037ce08a8d85753d 100644 (file)
@@ -8,7 +8,7 @@ require xorg-lib-common.inc
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=96254c20ab81c63e65b26f0dbcd4a1c1"
 
-DEPENDS += "zlib xproto font-util"
+DEPENDS += "zlib xorgproto font-util"
 PE = "1"
 
 BBCLASSEXTEND = "native"
index f069749ce061a9ea6e72f1b4986a9f62d146e469..0337d2118910a05860bc67736d620b136eed65a7 100644 (file)
@@ -11,7 +11,7 @@ require xorg-lib-common.inc
 LICENSE = "MIT-style"
 LIC_FILES_CHKSUM = "file://COPYING;md5=d162b1b3c6fa812da9d804dcf8584a93"
 
-DEPENDS += "xproto xtrans"
+DEPENDS += "xorgproto xtrans"
 PROVIDES = "ice"
 
 PE = "1"
index 48922cb99218d61f3a0daba892233e08ac5484ac..fdc693be1424ea350d932378dd32d40a47b02f41 100644 (file)
@@ -11,7 +11,7 @@ require xorg-lib-common.inc
 LICENSE = "MIT-style"
 LIC_FILES_CHKSUM = "file://COPYING;md5=c0fb37f44e02bdbde80546024400728d"
 
-DEPENDS += "libice xproto xtrans"
+DEPENDS += "libice xorgproto xtrans"
 
 # libSM can work without libuuid, we explicitly disable it to break the following circular dependency
 # when DISTRO_FEATURES contains 'systemd' and 'x11'.
index 4af40ab8a1c26afc39973dc40f1c771d8f407a4d..d9a2b52ad69b8d938c6178034998627e8032016e 100644 (file)
@@ -18,8 +18,8 @@ XORG_PN = "libX11"
 LICENSE = "MIT & MIT-style & BSD"
 LIC_FILES_CHKSUM = "file://COPYING;md5=172255dee66bb0151435b2d5d709fcf7"
 
-DEPENDS += "xproto xextproto xtrans libxcb kbproto inputproto"
-DEPENDS += "xproto-native"
+DEPENDS += "xorgproto xtrans libxcb"
+DEPENDS += "xorgproto-native"
 
 EXTRA_OECONF += "--with-keysymdefdir=${STAGING_INCDIR}/X11/ --disable-xf86bigfont"
 EXTRA_OEMAKE += 'CWARNFLAGS=""'
index 2ef8bfa8b6bafee7d9ef3886a7b3f6f24ee82609..8c52475b85566f2b6241080c8c8552c11e65af0d 100644 (file)
@@ -11,7 +11,7 @@ inherit gettext
 LICENSE = "MIT-style"
 LIC_FILES_CHKSUM = "file://COPYING;md5=7908e342491198401321cec1956807ec"
 
-DEPENDS += " xproto"
+DEPENDS += " xorgproto"
 PROVIDES = "xau"
 
 PE = "1"
index 0fe65318bea7ba0d738296b0d6c212f8760d483f..0ed8fda1698e4f63c9f6dc548d3ad02f7711f541 100644 (file)
@@ -9,7 +9,7 @@ LICENSE = "MIT-style"
 LIC_FILES_CHKSUM = "file://xcalibrate.h;endline=21;md5=fa572df6439f0f235f2612f370f153d7 \
                     file://xcalibrate.c;endline=21;md5=fa572df6439f0f235f2612f370f153d7"
 
-DEPENDS = "virtual/libx11 calibrateproto libxext"
+DEPENDS = "virtual/libx11 xorgproto libxext"
 
 SRCREV = "209d83af61ed38a002c8096377deac292b3e396c"
 PV = "0.0+git${SRCPV}"
index 04b58ea49f4c666d7d64b95005d095547116ddb0..a8e0307e1a96638a1cd1c9b5232b3857d72ac9fd 100644 (file)
@@ -20,7 +20,7 @@ SRC_URI[sha256sum] = "188c8752193c50ff2dbe89db4554c63df2e26a2e47b0fa415a70918b5b
 
 BBCLASSEXTEND = "native nativesdk"
 
-DEPENDS = "xcb-proto xproto libxau libpthread-stubs libxdmcp"
+DEPENDS = "xcb-proto xorgproto libxau libpthread-stubs libxdmcp"
 
 PACKAGES_DYNAMIC = "^libxcb-.*"
 
index 70257194a91493b246caddfe7d72a6fe77ab9140..73e29484047d6188880f8498563c0d19e07f89aa 100644 (file)
@@ -14,7 +14,7 @@ require xorg-lib-common.inc
 LICENSE = "MIT-style"
 LIC_FILES_CHKSUM = "file://COPYING;md5=3f2907aad541f6f226fbc58cc1b3cdf1"
 
-DEPENDS += " compositeproto virtual/libx11 libxfixes libxext"
+DEPENDS += " xorgproto virtual/libx11 libxfixes libxext"
 PROVIDES = "xcomposite"
 BBCLASSEXTEND = "native"
 
index c3d70043cad0bab1e4ee70819360150ae12f9a77..6d6ffadf209b30b5373d5c3852a075b6575222e3 100644 (file)
@@ -16,7 +16,7 @@ require xorg-lib-common.inc
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=9fe101f30dd24134cf43146863241868"
 
-DEPENDS += "virtual/libx11 damageproto libxfixes"
+DEPENDS += "virtual/libx11 xorgproto libxfixes"
 PROVIDES = "xdamage"
 BBCLASSEXTEND = "native"
 
index f4e30d93d48e766dcf5993d73e13705c5dead480..466f3491fdccb61ab10c0cb78640ed42cd5c1089 100644 (file)
@@ -13,7 +13,7 @@ inherit gettext
 LICENSE = "MIT-style"
 LIC_FILES_CHKSUM = "file://COPYING;md5=d559fb26e129626022e052a5e6e0e123"
 
-DEPENDS += "xproto"
+DEPENDS += "xorgproto"
 PROVIDES = "xdmcp"
 
 PE = "1"
index 063e531c02927ff50fbca247b95dd4feec689404..aae8f2af6d930bb7888cd9673cd1e1cfea6dfe33 100644 (file)
@@ -13,7 +13,7 @@ require xorg-lib-common.inc
 LICENSE = "MIT-style"
 LIC_FILES_CHKSUM = "file://COPYING;md5=879ce266785414bd1cbc3bc2f4d9d7c8"
 
-DEPENDS += "xproto virtual/libx11 xextproto"
+DEPENDS += "xorgproto virtual/libx11"
 PROVIDES = "xext"
 
 PE = "1"
index c80042d3495cd1f68792b439eeeb63d6d88ed53b..f0e2f606cebca40344650432e033019dcb31df11 100644 (file)
@@ -10,7 +10,7 @@ require xorg-lib-common.inc
 LICENSE = "MIT-style"
 LIC_FILES_CHKSUM = "file://COPYING;md5=3c1ce42c334a6f5cccb0277556a053e0"
 
-DEPENDS += "virtual/libx11 xproto fixesproto xextproto"
+DEPENDS += "virtual/libx11 xorgproto"
 
 PE = "1"
 
index 5f27a55827b22c4c5b06708a5660a18433d6f4d3..2b72d6750c564d5fff693ca7a9456d9a8bdc938e 100644 (file)
@@ -9,7 +9,7 @@ require xorg-lib-common.inc
 LICENSE = "MIT & MIT-style & BSD"
 LIC_FILES_CHKSUM = "file://COPYING;md5=a46c8040f2f737bcd0c435feb2ab1c2c"
 
-DEPENDS += "freetype xtrans fontsproto libfontenc zlib"
+DEPENDS += "freetype xtrans xorgproto libfontenc zlib"
 
 XORG_PN = "libXfont2"
 
index 79f77fceacd2253da330342ad7bd213ce4cf99a6..94c6c66e878872068edd8997aa1c7ed421c7c090 100644 (file)
@@ -9,7 +9,7 @@ require xorg-lib-common.inc
 LICENSE = "MIT & MIT-style & BSD"
 LIC_FILES_CHKSUM = "file://COPYING;md5=a46c8040f2f737bcd0c435feb2ab1c2c"
 
-DEPENDS += "freetype xtrans fontsproto libfontenc zlib"
+DEPENDS += "freetype xtrans xorgproto libfontenc zlib"
 PROVIDES = "xfont"
 
 PE = "1"
index 74f0527b781a3e85be0e0928d18451694f7aa89c..08381d9c4d51d3cae8298526cfaee834a21d3ec3 100644 (file)
@@ -11,7 +11,7 @@ LICENSE = "MIT & MIT-style"
 LIC_FILES_CHKSUM = "file://COPYING;md5=17b064789fab936a1c58c4e13d965b0f \
                     file://src/XIGetDevFocus.c;endline=23;md5=cdfb0d435a33ec57ea0d1e8e395b729f"
 
-DEPENDS += "libxext inputproto libxfixes"
+DEPENDS += "libxext xorgproto libxfixes"
 
 PE = "1"
 
index bb03f44e25ad7854b10131aa6609ae3a414d164c..367ad262be72267426da5651c2543233d1c77492 100644 (file)
@@ -10,7 +10,7 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=6f4f634d1643a2e638bba3fcd19c2536 \
                     file://src/Xinerama.c;beginline=2;endline=25;md5=fcef273bfb66339256411dd06ea79c02"
 
-DEPENDS += "libxext xineramaproto"
+DEPENDS += "libxext xorgproto"
 PROVIDES = "xinerama"
 PE = "1"
 
index 39a344ccade481f5b9058a2ca22893cedd01b380..f5c18607ac8f33667dc811d60f069e7ccfcd5fae 100644 (file)
@@ -8,7 +8,7 @@ require xorg-lib-common.inc
 LICENSE = "MIT-style"
 LIC_FILES_CHKSUM = "file://COPYING;md5=8be7367f7e5d605a426f76bb37d4d61f"
 
-DEPENDS += "virtual/libx11 kbproto"
+DEPENDS += "virtual/libx11 xorgproto"
 
 PE = "1"
 
index 48e88d20a72fdfa28df0bb7867dd598379c5684c..b90ebc6232966d891274505eb2840aeb6e3d2fdd 100644 (file)
@@ -11,7 +11,7 @@ require xorg-lib-common.inc
 LICENSE = "MIT-style"
 LIC_FILES_CHKSUM = "file://COPYING;md5=c9d1a2118a6cd5727521db8e7a2fee69"
 
-DEPENDS += "virtual/libx11 randrproto libxrender libxext"
+DEPENDS += "virtual/libx11 xorgproto libxrender libxext"
 
 PE = "1"
 
index 92b3102704fff29e18aa8e4d9e5775384ad6599e..9b18366138b46acde736138ca03ea5a5e273dae0 100644 (file)
@@ -11,7 +11,7 @@ require xorg-lib-common.inc
 LICENSE = "MIT-style"
 LIC_FILES_CHKSUM = "file://COPYING;md5=d8bc71986d3b9b3639f6dfd6fac8f196"
 
-DEPENDS += "virtual/libx11 renderproto xproto"
+DEPENDS += "virtual/libx11 xorgproto"
 
 PE = "1"
 
index 8c34e47b43f0b4ce21db56057a6a9c1c7a29c929..af6bb19a2583343e1d74b91f62bcd5335a30b4ab 100644 (file)
@@ -10,7 +10,7 @@ require xorg-lib-common.inc
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=8c89441a8df261bdc56587465e13c7fa"
 
-DEPENDS += "libxext resourceproto"
+DEPENDS += "libxext xorgproto"
 
 PE = "1"
 
index 354e5de7fdb6eedc31501460a6925e4c635e925f..ddf09af05f029a24521009c311535114af0e411b 100644 (file)
@@ -12,7 +12,7 @@ image is to be displayed and to provide the graphics."
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=21fd154ee757813632ada871a34113fb"
 
-DEPENDS += "libxext scrnsaverproto"
+DEPENDS += "libxext xorgproto"
 PROVIDES = "libxss"
 RREPLACES_${PN} = "libxss"
 PE = "1"
index 180d00d9b08747ceea11c619374be33cb817b269..f8d94a2f546a4986134649994016eccd4e9dcb90 100644 (file)
@@ -16,7 +16,7 @@ LICENSE = "MIT & MIT-style"
 LIC_FILES_CHKSUM = "file://COPYING;md5=6565b1e0094ea1caae0971cc4035f343"
 
 
-DEPENDS += "util-linux libxcb libsm virtual/libx11 kbproto libxdmcp"
+DEPENDS += "util-linux libxcb libsm virtual/libx11 xorgproto libxdmcp"
 PROVIDES = "xt"
 
 PE = "1"
index 5717fa5b79452b46a7a83ed7466bf6891ae9cfc2..266bd1ca59c9089480bc45ab089aba05f594e751 100644 (file)
@@ -10,7 +10,7 @@ LICENSE = "MIT-style"
 LIC_FILES_CHKSUM = "file://COPYING;md5=bb4f89972c3869f617f61c1a79ad1952 \
                     file://src/XTest.c;beginline=2;endline=32;md5=b1c8c9dff842b4d5b89ca5fa32c40e99"
 
-DEPENDS += "libxext recordproto inputproto libxi"
+DEPENDS += "libxext xorgproto libxi"
 PROVIDES = "xtst"
 PE = "1"
 
index a226c2753a8d452025455e7ca0639b6cca789ac8..c6027233ef6100ca942f287b60383151b36210b3 100644 (file)
@@ -10,7 +10,7 @@ require xorg-lib-common.inc
 LICENSE = "MIT-style"
 LIC_FILES_CHKSUM = "file://COPYING;md5=827da9afab1f727f2a66574629e0f39c"
 
-DEPENDS += "libxext videoproto"
+DEPENDS += "libxext xorgproto"
 
 XORG_PN = "libXv"
 
index 6ed49b1f37c70d4bfe4267bbbc1185bdcd22f8b9..7e49a98ddb54cfc4c4261a237b8c871a5be4ecd5 100644 (file)
@@ -9,7 +9,7 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=0a207f08d4961489c55046c9a5e500da \
                     file://wrapper/XvMCWrapper.c;endline=26;md5=5151daa8172a3f1bb0cb0e0ff157d9de"
 
-DEPENDS += "libxext libxv videoproto"
+DEPENDS += "libxext libxv xorgproto"
 
 PE = "1"
 
index 695a39637c8bb58c3f80c29534999b7ee57b3021..626199e09c03b1d328362f460ff7f6fccb990d57 100644 (file)
@@ -9,7 +9,7 @@ emulators for games."
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=abb99ac125f84f424a4278153988e32f"
 
-DEPENDS += "libxext xf86dgaproto"
+DEPENDS += "libxext"
 
 PE = "1"
 
index af6f1f76a2f1ad391cb74522bc4d11072a72d685..04fe9626287e5e5e8ed5a3d412e6ec19ae3588f0 100644 (file)
@@ -8,7 +8,7 @@ require xorg-lib-common.inc
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=27c91ecc435bd3d2bfad868914c94b45"
 
-DEPENDS += "libxext xf86miscproto"
+DEPENDS += "libxext"
 PROVIDES = "xxf86misc"
 
 PE = "1"
index 35f87d2719d9c87b29f753fe2feb7d5d19651b57..95fc0b642c64f3a4e2243af390399a8907594367 100644 (file)
@@ -10,7 +10,7 @@ require xorg-lib-common.inc
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=fa0b9c462d8f2f13eba26492d42ea63d"
 
-DEPENDS += "libxext xf86vidmodeproto"
+DEPENDS += "libxext xorgproto"
 
 PE = "1"
 
index 84a967a81e3117d50a7912d0b8d3c248021a21d5..727ab5496556d8f9fc3399c77fb9177844f2f04c 100644 (file)
@@ -10,7 +10,7 @@ directives would be used in a compilation. Any #include, directives \
 can reference files having other #include directives, and parsing will \
 occur in these files as well."
 
-DEPENDS = "xproto util-macros"
+DEPENDS = "xorgproto util-macros"
 PE = "1"
 
 BBCLASSEXTEND = "native"
index cf2286c65328ec2760b2502c3e136efe7abb68fa..882897bd25de6f781a3de483e6bdaf0823278ea5 100644 (file)
@@ -26,7 +26,7 @@ inherit autotools pkgconfig
 inherit distro_features_check
 REQUIRED_DISTRO_FEATURES = "x11"
 
-PROTO_DEPS = "randrproto renderproto fixesproto damageproto xextproto xproto xf86dgaproto xf86miscproto xf86vidmodeproto compositeproto recordproto resourceproto videoproto scrnsaverproto  xineramaproto fontsproto kbproto inputproto bigreqsproto xcmiscproto presentproto"
+PROTO_DEPS = "xorgproto"
 LIB_DEPS = "pixman libxfont2 xtrans libxau libxext libxdmcp libdrm libxkbfile libpciaccess"
 DEPENDS = "${PROTO_DEPS} ${LIB_DEPS} font-util"
 
@@ -127,18 +127,18 @@ PACKAGECONFIG ??= "dri2 udev ${XORG_CRYPTO} \
 "
 
 PACKAGECONFIG[udev] = "--enable-config-udev,--disable-config-udev,udev"
-PACKAGECONFIG[dri] = "--enable-dri,--disable-dri,glproto virtual/mesa xf86driproto"
-PACKAGECONFIG[dri2] = "--enable-dri2,--disable-dri2,dri2proto"
+PACKAGECONFIG[dri] = "--enable-dri,--disable-dri,xorgproto virtual/mesa"
+PACKAGECONFIG[dri2] = "--enable-dri2,--disable-dri2,xorgproto"
 # DRI3 requires xshmfence to also be enabled
-PACKAGECONFIG[dri3] = "--enable-dri3,--disable-dri3,dri3proto"
-PACKAGECONFIG[glx] = "--enable-glx,--disable-glx,glproto virtual/libgl virtual/libx11"
+PACKAGECONFIG[dri3] = "--enable-dri3,--disable-dri3,xorgproto"
+PACKAGECONFIG[glx] = "--enable-glx,--disable-glx,xorgproto virtual/libgl virtual/libx11"
 PACKAGECONFIG[glamor] = "--enable-glamor,--disable-glamor,libepoxy virtual/libgbm,libegl"
 PACKAGECONFIG[unwind] = "--enable-libunwind,--disable-libunwind,libunwind"
 PACKAGECONFIG[xshmfence] = "--enable-xshmfence,--disable-xshmfence,libxshmfence"
 PACKAGECONFIG[xmlto] = "--with-xmlto, --without-xmlto, xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native"
 PACKAGECONFIG[systemd-logind] = "--enable-systemd-logind=yes,--enable-systemd-logind=no,dbus,"
 PACKAGECONFIG[systemd] = "--with-systemd-daemon,--without-systemd-daemon,systemd"
-PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,xineramaproto"
+PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,xorgproto"
 PACKAGECONFIG[xwayland] = "--enable-xwayland,--disable-xwayland,wayland wayland-native wayland-protocols libepoxy"
 
 # Xorg requires a SHA1 implementation, pick one