]> code.ossystems Code Review - openembedded-core.git/commitdiff
cups: Fix recipe to use the correct cups directories
authorMark Hatle <mark.hatle@windriver.com>
Thu, 22 Sep 2011 17:12:09 +0000 (12:12 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 22 Sep 2011 20:00:48 +0000 (21:00 +0100)
${libdir} is not used, instead they use a common ${exec_prefix}/lib
directory structure for helpers, filters, renderers, etc.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/cups/cups14.inc
meta/recipes-extended/cups/cups_1.4.6.bb

index e64f239a6a9a233c0abe3ae503180f740bee6c29..48f493d6c73c7fbe18cb95ab6c8f6300d7b6df61 100644 (file)
@@ -64,16 +64,24 @@ python do_package_append() {
 
 PACKAGES =+ "${PN}-lib ${PN}-libimage"
 
+FILES_${PN} += "${exec_prefix}/lib/cups/backend \
+               ${exec_prefix}/lib/cups/cgi-bin \
+               ${exec_prefix}/lib/cups/filter \
+               ${exec_prefix}/lib/cups/monitor \
+               ${exec_prefix}/lib/cups/notifier \
+               ${exec_prefix}/lib/cups/daemon \
+              "
+
 FILES_${PN}-lib = "${libdir}/libcups.so.*"
 
 FILES_${PN}-libimage = "${libdir}/libcupsimage.so.*"
 
-FILES_${PN}-dbg += "${libdir}/cups/backend/.debug \
-                    ${libdir}/cups/cgi-bin/.debug \
-                    ${libdir}/cups/filter/.debug \
-                    ${libdir}/cups/monitor/.debug \
-                    ${libdir}/cups/notifier/.debug \
-                    ${libdir}/cups/daemon/.debug \
+FILES_${PN}-dbg += "${exec_prefix}/lib/cups/backend/.debug \
+                    ${exec_prefix}/lib/cups/cgi-bin/.debug \
+                    ${exec_prefix}/lib/cups/filter/.debug \
+                    ${exec_prefix}/lib/cups/monitor/.debug \
+                    ${exec_prefix}/lib/cups/notifier/.debug \
+                    ${exec_prefix}/lib/cups/daemon/.debug \
                    "
 
 #package the html for the webgui inside the main packages (~1MB uncompressed)
index fd20dcceebb1600eef64a427fa681e9c00c07c3f..0dc2d4a26b037fd34a228736a6347e2624d5c931 100644 (file)
@@ -1,6 +1,6 @@
 require cups14.inc
 
-PR = "r1"
+PR = "r2"
 DEPENDS += "libusb \
        ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"