]> code.ossystems Code Review - openembedded-core.git/commitdiff
resolvconf: specify configuration for systemd-tmpfiles --update
authorJonathan Liu <net147@gmail.com>
Thu, 5 Sep 2013 05:24:39 +0000 (15:24 +1000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 6 Sep 2013 22:01:51 +0000 (23:01 +0100)
Running systemd-tmpfiles --update without specifying a configuration
file results in all tmpfiles.d configuration files being processed.

/usr/lib/tmpfiles.d/systemd.conf creates /run/nologin on boot to
prevent non-root users from logging in while the system is booting.
If systemd-tmpfiles --update is run after the system has started,
it will still create /run/nologin which would prevent non-root users
from logging in with the message "System is booting up.".

Signed-off-by: Jonathan Liu <net147@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/resolvconf/resolvconf_1.74.bb

index eb1ce8d76f6cf3d754073aee2d6a719b672b1987..5897e40489b0412c713c0085c25d46ab6da9ff8f 100644 (file)
@@ -45,7 +45,7 @@ do_install () {
 pkg_postinst_${PN} () {
        if [ -z "$D" ]; then
                if command -v systemd-tmpfiles >/dev/null; then
-                       systemd-tmpfiles --create
+                       systemd-tmpfiles --create ${sysconfdir}/tmpfiles.d/resolvconf.conf
                elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then
                        ${sysconfdir}/init.d/populate-volatile.sh update
                fi