]> code.ossystems Code Review - openembedded-core.git/commitdiff
pixman,libpciaccess: Fix build on musl
authorKhem Raj <raj.khem@gmail.com>
Mon, 6 Apr 2015 17:36:49 +0000 (17:36 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 8 Apr 2015 09:45:26 +0000 (10:45 +0100)
The fixes are not specific to musl, however they came
to surface due to musl, these are generic problems which
should be fixed in components

Change-Id: If9aa95968d9dec9c16e3e5819955befcaa38937c
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/xorg-lib/libpciaccess/limits.patch [new file with mode: 0644]
meta/recipes-graphics/xorg-lib/libpciaccess_0.13.3.bb
meta/recipes-graphics/xorg-lib/pixman/asm_include.patch [new file with mode: 0644]
meta/recipes-graphics/xorg-lib/pixman_0.32.6.bb

diff --git a/meta/recipes-graphics/xorg-lib/libpciaccess/limits.patch b/meta/recipes-graphics/xorg-lib/libpciaccess/limits.patch
new file mode 100644 (file)
index 0000000..498020e
--- /dev/null
@@ -0,0 +1,17 @@
+Add missing include file to get definition of PATH_MAX
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Pending
+
+Index: libpciaccess-0.13.3/src/linux_sysfs.c
+===================================================================
+--- libpciaccess-0.13.3.orig/src/linux_sysfs.c
++++ libpciaccess-0.13.3/src/linux_sysfs.c
+@@ -44,6 +44,7 @@
+ #include <sys/mman.h>
+ #include <dirent.h>
+ #include <errno.h>
++#include <limits.h>
+ #if defined(__i386__) || defined(__x86_64__) || defined(__arm__)
+ #include <sys/io.h>
index bbba24eb9a13eba5af3cfe5cc67f6f88976766ec..4a832e8ccb3c84e8a616d895c84954fa26f9d1f2 100644 (file)
@@ -5,6 +5,8 @@ PCI bus and devices in a platform-independent way."
 
 require xorg-lib-common.inc
 
+SRC_URI += "file://limits.patch"
+
 LICENSE = "MIT & MIT-style"
 LIC_FILES_CHKSUM = "file://COPYING;md5=277aada5222b9a22fbf3471ff3687068"
 
diff --git a/meta/recipes-graphics/xorg-lib/pixman/asm_include.patch b/meta/recipes-graphics/xorg-lib/pixman/asm_include.patch
new file mode 100644 (file)
index 0000000..b52a570
--- /dev/null
@@ -0,0 +1,29 @@
+Fixes errors like
+
+Assembler messages:
+Fatal error: can't create .libs/pixman-mips-dspr2-asm.o: No such file or directory
+
+it works with glibc because it uses gcc fixed-headers but thats not right.
+
+We move the include under C block
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Pending
+Index: pixman-0.32.6/pixman/pixman-private.h
+===================================================================
+--- pixman-0.32.6.orig/pixman/pixman-private.h
++++ pixman-0.32.6/pixman/pixman-private.h
+@@ -1,4 +1,3 @@
+-#include <float.h>
+ #ifndef PIXMAN_PRIVATE_H
+ #define PIXMAN_PRIVATE_H
+@@ -17,6 +16,8 @@
+ #ifndef __ASSEMBLER__
++#include <float.h>
++
+ #ifndef PACKAGE
+ #  error config.h must be included before pixman-private.h
+ #endif
index 467ba508ee1614a69da9d28a5e009ab02514039d..eae59b62d2e7a629d2178d084bb17a564d34a03a 100644 (file)
@@ -30,6 +30,7 @@ EXTRA_OECONF_class-native = "--disable-gtk"
 SRC_URI += "\
             file://0001-ARM-qemu-related-workarounds-in-cpu-features-detecti.patch \
             file://mips-export-revert.patch \
+           file://asm_include.patch \
 "
 
 SRC_URI[md5sum] = "8a9e8f14743a39cf303803f369c1f344"