]> code.ossystems Code Review - openembedded-core.git/commitdiff
mtd-utils: keep xattr support enabled
authorPatrick Ohly <patrick.ohly@intel.com>
Tue, 11 Aug 2015 08:45:00 +0000 (10:45 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 16 Aug 2015 16:28:13 +0000 (17:28 +0100)
xattrs may be needed by some distros. Support that by compiling in the
necessary code, even if it is not used by default. Then .jffs2 images
including xattrs can be created with:

   EXTRA_IMAGECMD_jffs2_append = " --with-xattr"

Signed-off-by: Patrick Ohly <patrick.ohly@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/mtd/mtd-utils_git.bb

index 7010cac1458a55a38a2ab6419c4eac6d51d11600..8d4892a0d440e8a2cd6c2aed6ee3e25270380762 100644 (file)
@@ -19,7 +19,7 @@ SRC_URI = "git://git.infradead.org/mtd-utils.git \
 
 S = "${WORKDIR}/git/"
 
-EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'BUILDDIR=${S}'"
+EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include' 'BUILDDIR=${S}'"
 
 do_install () {
        oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} INCLUDEDIR=${includedir}