]> code.ossystems Code Review - openembedded-core.git/commitdiff
gtk+-2.12: Tweak filechooser size patch
authorRichard Purdie <richard@openedhand.com>
Fri, 29 Feb 2008 17:45:52 +0000 (17:45 +0000)
committerRichard Purdie <richard@openedhand.com>
Fri, 29 Feb 2008 17:45:52 +0000 (17:45 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3880 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/gtk+/gtk+-2.12.7/filechooser-sizefix.patch
meta/packages/gtk+/gtk+_2.12.7.bb

index 11ec6a269737ed319ad8625c1c4979f5bacd31cf..4de68dfb98894495ff8952b6ba0c122375103542 100644 (file)
@@ -1,15 +1,31 @@
-Index: gtk+-2.12.7/gtk/gtkfilechooserdefault.c
-===================================================================
---- gtk+-2.12.7.orig/gtk/gtkfilechooserdefault.c       2008-02-29 15:04:29.000000000 +0000
-+++ gtk+-2.12.7/gtk/gtkfilechooserdefault.c    2008-02-29 15:05:23.000000000 +0000
+
+diff -ur /tmp/gtk+-2.12.7/gtk/gtkfilechooserdefault.c ./gtk/gtkfilechooserdefault.c
+--- /tmp/gtk+-2.12.7/gtk/gtkfilechooserdefault.c       2008-02-29 17:00:14.000000000 +0000
++++ ./gtk/gtkfilechooserdefault.c      2008-02-29 17:25:21.000000000 +0000
 @@ -178,8 +178,8 @@
  #define FALLBACK_ICON_SIZE 24
  
  #define LIST_HBOX_SPACING DEFAULT_SPACING
 -#define NUM_LINES 45
 -#define NUM_CHARS 60
-+#define NUM_LINES 15
-+#define NUM_CHARS 20
++#define NUM_LINES 10
++#define NUM_CHARS 12
  
  static void gtk_file_chooser_default_iface_init       (GtkFileChooserIface        *iface);
  static void gtk_file_chooser_embed_default_iface_init (GtkFileChooserEmbedIface   *iface);
+diff -ur /tmp/gtk+-2.12.7/gtk/gtkfilechooserdialog.c ./gtk/gtkfilechooserdialog.c
+--- /tmp/gtk+-2.12.7/gtk/gtkfilechooserdialog.c        2008-01-30 03:11:07.000000000 +0000
++++ ./gtk/gtkfilechooserdialog.c       2008-02-29 17:20:30.000000000 +0000
+@@ -165,10 +165,10 @@
+   gdk_screen_get_monitor_geometry (screen, monitor_num, &monitor);
+   if (width)
+-    *width = MIN (*width, (monitor.width * 3) / 4);
++    *width = MIN (*width, monitor.width);
+   if (height)
+-    *height = MIN (*height, (monitor.height * 3) / 4);
++    *height = MIN (*height, monitor.height);
+ }
+ static void
index bddddde51bf8a3f7eeacd57b33808a3ad38dcdc6..f66b4b80b2da256e58ae03e93886cd155f669fdf 100644 (file)
@@ -1,7 +1,7 @@
 require gtk+.inc
 
 DEPENDS += "cairo"
-PR = "r4"
+PR = "r5"
 
 SRC_URI = "http://download.gnome.org/sources/gtk+/2.12/gtk+-${PV}.tar.bz2 \
            file://xsettings.patch;patch=1 \