]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxcrypt: add -std=gnu99 to BUILD_CPPFLAGS
authorMartin Jansa <martin.jansa@gmail.com>
Mon, 9 Apr 2018 07:51:41 +0000 (07:51 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 9 Apr 2018 11:11:50 +0000 (12:11 +0100)
* add it to allow older distributions e.g. Ubuntu 14.04 with gcc 4.8
  to build this, otherwise it fails with:
  ../git/gen-des-tables.c: In function 'write_table_u8':
  ../git/gen-des-tables.c:307:3: error: 'for' loop initial declarations are only allowed in C99 mode
     for (size_t i = 0; i < m; i++)
     ^

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/libxcrypt/libxcrypt_4.0.0.bb

index b1982c1991e21ad7b004c432930cacb63ef2e0ad..a1be4be7eff04e7db229238c0d71678cfb5230cd 100644 (file)
@@ -20,7 +20,7 @@ FILES_${PN} = "${libdir}/libcrypt*.so.* ${libdir}/libcrypt-*.so ${libdir}/libowc
 
 S = "${WORKDIR}/git"
 
-BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
+BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE} -std=gnu99"
 TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
 
 python () {