]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxml2: Fix a compilation error when using -D_FORTIFY_SOURCE=2 thanks Chenglan Huang
authorJoshua Lock <josh@linux.intel.com>
Fri, 31 Oct 2008 15:20:31 +0000 (15:20 +0000)
committerJoshua Lock <josh@linux.intel.com>
Fri, 31 Oct 2008 15:25:24 +0000 (15:25 +0000)
meta/packages/libxml/files/libxml-nanohttp.patch [new file with mode: 0644]
meta/packages/libxml/libxml2-native_2.6.29.bb
meta/packages/libxml/libxml2.inc
meta/packages/libxml/libxml2_2.6.29.bb

diff --git a/meta/packages/libxml/files/libxml-nanohttp.patch b/meta/packages/libxml/files/libxml-nanohttp.patch
new file mode 100644 (file)
index 0000000..550e036
--- /dev/null
@@ -0,0 +1,13 @@
+Index: libxml2-2.6.29/nanohttp.c
+===================================================================
+--- libxml2-2.6.29.orig/nanohttp.c     2008-10-30 10:12:11.000000000 +0800
++++ libxml2-2.6.29/nanohttp.c  2008-10-30 10:12:30.000000000 +0800
+@@ -1585,7 +1585,7 @@
+     if (!strcmp(filename, "-")) 
+         fd = 0;
+     else {
+-        fd = open(filename, O_CREAT | O_WRONLY);
++        fd = open(filename, O_CREAT | O_WRONLY, 0644);
+       if (fd < 0) {
+           xmlNanoHTTPClose(ctxt);
+           return(-1);
index 431d81d1d707ca893f4c8ece7a513bf2734c4253..da79c9bb4e528169afb006ece1da14f0da23fab6 100644 (file)
@@ -1,6 +1,6 @@
 require libxml2.inc
 
-PR = "r7"
+PR = "r8"
 
 DEPENDS += "python-native"
 
index 4e6e52760322ba04e0b8fbf8cff4acdf6814084d..e8b03cf02d882cb3d036409b33a763eb8c71a0e1 100644 (file)
@@ -4,7 +4,8 @@ PRIORITY = "optional"
 LICENSE = "MIT"
 
 SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz \
-           file://libxml-64bit.patch;patch=1"
+           file://libxml-64bit.patch;patch=1 \
+          file://libxml-nanohttp.patch;patch=1"
 
 inherit autotools pkgconfig binconfig
 
index 3b4bac673a32b05e61bd2e00c2b50721e0caa74f..2f583c2c302a00aa971220f11f077b5b3f16fc2f 100644 (file)
@@ -1,6 +1,6 @@
 require libxml2.inc
 
-PR = "r6"
+PR = "r7"
 
 export LDFLAGS += "-ldl"