]> code.ossystems Code Review - openembedded-core.git/commitdiff
python: skip setup.py 'import check' when cross-compiling
authorTom Zanussi <tom.zanussi@intel.com>
Sat, 5 Nov 2011 01:25:03 +0000 (20:25 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 8 Nov 2011 21:44:23 +0000 (21:44 +0000)
build_extension() in setup.py, as part of the build process, does an
'import check' on the built extension.  The import check in turn
dlopen()'s the shared library associated with the extension, which
isn't something that makes sense if that library was cross-compiled
for a different architecture.

This was noticed with an x86_64 target that was compiled with avx
support, because it caused 'illegal instruction' exceptions:

| /bin/sh: line 1: 14575 Illegal instruction ... -E ./setup.py -q build

For other target architectures, it doesn't necessarily cause illegal
instruction exceptions, but still fails.  For example, on arm, the
failure pathway causes this warning:

*** WARNING: renaming "cmath" since importing it failed: .../cmath.so:
    wrong ELF class: ELFCLASS32

This patch to setup.py and the associated recipe changes allow the
whole 'import check' logic to be skipped when cross-compiling.

Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
meta/recipes-devtools/python/python/setup_py_skip_cross_import_check.patch [new file with mode: 0644]
meta/recipes-devtools/python/python_2.7.2.bb

diff --git a/meta/recipes-devtools/python/python/setup_py_skip_cross_import_check.patch b/meta/recipes-devtools/python/python/setup_py_skip_cross_import_check.patch
new file mode 100644 (file)
index 0000000..6ccdb94
--- /dev/null
@@ -0,0 +1,27 @@
+This patch skips over the 'import check' setup.py does when building
+extensions.  This generally won't work when cross-compiling.
+
+Upstream-Status: Inappropriate [embedded-specific]
+
+Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
+
+Index: Python-2.7.2/setup.py
+===================================================================
+--- Python-2.7.2.orig/setup.py 2011-11-04 16:46:34.553796410 -0500
++++ Python-2.7.2/setup.py      2011-11-04 16:59:49.692802313 -0500
+@@ -287,6 +287,15 @@
+                           (ext.name, sys.exc_info()[1]))
+             self.failed.append(ext.name)
+             return
++
++        # If we're cross-compiling, we want to skip the import check
++        # i.e. we shouldn't be dynamically loading target shared libs
++        if os.environ.get('CROSS_COMPILE') is not None:
++            self.announce(
++                'WARNING: skipping import check for cross-compiled "%s"' %
++                ext.name)
++            return
++
+         # Workaround for Mac OS X: The Carbon-based modules cannot be
+         # reliably imported into a command-line Python
+         if 'Carbon' in ext.extra_link_args:
index bb088a4620f9f6a703d7a77d4338963c7bcbbcc7..360e64e9a6ac13202c8bd15eb9aee3c75d64fa02 100644 (file)
@@ -18,6 +18,7 @@ SRC_URI += "\
   file://multilib.patch \
   file://cgi_py.patch \
   file://remove_sqlite_rpath.patch \
+  file://setup_py_skip_cross_import_check.patch \
 "
 
 S = "${WORKDIR}/Python-${PV}"
@@ -57,6 +58,8 @@ do_compile() {
        # then call do_install twice we get Makefile.orig == Makefile.sysroot
        install -m 0644 Makefile Makefile.sysroot
 
+       export CROSS_COMPILE="${TARGET_PREFIX}"
+
        oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \
                HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python \
                STAGING_LIBDIR=${STAGING_LIBDIR} \
@@ -78,6 +81,8 @@ do_install() {
        # make install needs the original Makefile, or otherwise the inclues would
        # go to ${D}${STAGING...}/...
        install -m 0644 Makefile.orig Makefile
+
+       export CROSS_COMPILE="${TARGET_PREFIX}"
        
        oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \
                HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python \