]> code.ossystems Code Review - openembedded-core.git/commitdiff
recipetool: create: AX_PKG_SWIG should add dependency on swig-native
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Wed, 31 Aug 2016 03:15:55 +0000 (15:15 +1200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 7 Sep 2016 23:36:43 +0000 (00:36 +0100)
If AX_PKG_SWIG is found in configure.ac, then what's being looked for is
the swig binary, not swig for the target - so fix the dependency
accordingly.

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
scripts/lib/recipetool/create_buildsys.py

index f784f9468acf2c3908c762868a723d4b76df3da6..0ad748ef02b94a5d1b27728bdf981b09f671c051 100644 (file)
@@ -570,7 +570,7 @@ class AutotoolsRecipeHandler(RecipeHandler):
             elif keyword == 'AX_LIB_TAGLIB':
                 deps.append('taglib')
             elif keyword == 'AX_PKG_SWIG':
-                deps.append('swig')
+                deps.append('swig-native')
             elif keyword == 'AX_PROG_XSLTPROC':
                 deps.append('libxslt-native')
             elif keyword == 'AX_WITH_CURSES':