]> code.ossystems Code Review - openembedded-core.git/commitdiff
external-csl-toolchain: skip parsing if CSL_VER_MAIN isn't set
authorJoshua Lock <josh@linux.intel.com>
Wed, 22 Feb 2012 01:46:43 +0000 (17:46 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 22 Feb 2012 22:10:40 +0000 (22:10 +0000)
Signed-off-by: Joshua Lock <josh@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/meta/external-csl-toolchain.bb

index d15578bf786b558a59d8f4541e26f7bf1cb0a9fd..07c3e3065a121dc9bd8af710ede0f576ca7cc77a 100644 (file)
@@ -150,3 +150,11 @@ FILES_linux-libc-headers = "${includedir}/asm* \
 "
 FILES_gdbserver = "${bindir}/gdbserver ${libdir}/bin/sysroot-gdbserver"
 FILES_gdbserver-dbg = "${bindir}/.debug/gdbserver"
+
+CSL_VER_MAIN ??= ""
+
+python () {
+    if not d.getVar("CSL_VER_MAIN"):
+       raise bb.parse.SkipPackage("External CSL toolchain not configured (CSL_VER_MAIN not set).")
+}
+