]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl-native: fix parallel build
authorNitin A Kamble <nitin.a.kamble@intel.com>
Thu, 17 Feb 2011 00:39:21 +0000 (16:39 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 17 Feb 2011 23:19:39 +0000 (23:19 +0000)
perl native recipe was failing on 40-way system with the parallel build turned
on. With this patch the parallel build on 40 way build system is not failing.

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Passed 31 clean/build cycles on the 40-way.

Tested-by: Darren Hart <dvhart@linux.intel.com>
meta/recipes-devtools/perl/perl-5.12.2/parallel_build_fix.patch [new file with mode: 0644]
meta/recipes-devtools/perl/perl-native_5.12.2.bb
meta/recipes-devtools/perl/perl_5.12.2.bb

diff --git a/meta/recipes-devtools/perl/perl-5.12.2/parallel_build_fix.patch b/meta/recipes-devtools/perl/perl-5.12.2/parallel_build_fix.patch
new file mode 100644 (file)
index 0000000..476577e
--- /dev/null
@@ -0,0 +1,18 @@
+This patch fixes the parallel make issue on a 40 way build system
+
+Nitin A Kamble <nitin.a.kamble@intel.com>
+2011-02-16
+
+Index: perl-5.12.2/Makefile.SH
+===================================================================
+--- perl-5.12.2.orig/Makefile.SH       2010-09-06 16:30:32.000000000 -0700
++++ perl-5.12.2/Makefile.SH    2011-02-16 16:21:30.744143773 -0800
+@@ -198,6 +198,8 @@
+ $this_target: uni.data" ;;
+       Text/ParseWords) extra_dep="$extra_dep
+ $this_target: lib/auto/Scalar/Util.$dlext" ;;
++      POSIX) extra_dep="$extra_dep
++$this_target: lib/auto/Cwd/Cwd.$dlext" ;;
+     esac
+ done
index 790eae2cd5e884558fa52a5bf0fce213fc9577ed..5996494c9892b6c7719e7f47f82627e1082e8140 100644 (file)
@@ -4,7 +4,7 @@ SECTION = "libs"
 LICENSE = "Artistic|GPL"
 LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
                    file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
-PR = "r4"
+PR = "r5"
 
 LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
                     file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
@@ -12,6 +12,7 @@ LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
 SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
            file://Configure-multilib.patch;patch=1 \
            file://perl-configpm-switch.patch;patch=1 \
+           file://parallel_build_fix.patch \
            file://native-nopacklist.patch;patch=1 \
            file://native-perlinc.patch;patch=1"
 
index b27e20f4e32b401bfd6a82316f332bc3a3422336..ce9998601d49e9a963735cac51b9b6feeb465087 100644 (file)
@@ -8,7 +8,7 @@ PRIORITY = "optional"
 # We need gnugrep (for -I)
 DEPENDS = "virtual/db perl-native-${PV} grep-native"
 DEPENDS += "gdbm zlib"
-PR = "r0"
+PR = "r1"
 
 # 5.10.1 has Module::Build built-in
 PROVIDES += "libmodule-build-perl"
@@ -18,6 +18,7 @@ PROVIDES += "libmodule-build-perl"
 
 SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
         file://Makefile.patch;patch=1 \
+        file://parallel_build_fix.patch \
         file://Makefile.SH.patch;patch=1 \
         file://installperl.patch;patch=1 \
         file://perl-dynloader.patch;patch=1 \