]> code.ossystems Code Review - openembedded-core.git/commitdiff
asciidoc: use Python 3 port
authorRoss Burton <ross.burton@intel.com>
Wed, 27 Mar 2019 14:20:05 +0000 (14:20 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 29 Mar 2019 08:26:27 +0000 (08:26 +0000)
There's a sort-of-official port of asciidoc to Python 3.  Whilst the official
replacement is asciidoctor which is rewritten in Ruby, this is a fairly trivial
swap and removes Python 2 from core-image-sato builds entirely.

Moving forward we should evaluate asciidoctor, but that can wait.

Change the RDEPENDS so that python3 is only a dependency for target and
nativesdk builds, for native this can use the host python3.

Remove redundant DESTDIR export that isn't needed.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/asciidoc/asciidoc_8.6.9.bb

index 38164d55735d6a52cb9e87af942697b72c71403a..d0d15171ac45df82a9b38ce99bb0d9245da32413 100644 (file)
@@ -8,17 +8,20 @@ LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
                     file://COPYRIGHT;md5=029ad5428ba5efa20176b396222d4069"
 
-SRC_URI = "http://downloads.sourceforge.net/project/${BPN}/${BPN}/${PV}/${BP}.tar.gz"
-SRC_URI[md5sum] = "c59018f105be8d022714b826b0be130a"
-SRC_URI[sha256sum] = "78db9d0567c8ab6570a6eff7ffdf84eadd91f2dfc0a92a2d0105d323cab4e1f0"
+SRC_URI = "git://github.com/asciidoc/asciidoc-py3;protocol=https"
+SRCREV = "618f6e6f6b558ed1e5f2588cd60a5a6b4f881ca0"
+PV .= "+py3-git${SRCPV}"
 
-UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/asciidoc/files/"
+DEPENDS = "libxml2-native libxslt-native docbook-xml-dtd4-native"
 
+S = "${WORKDIR}/git"
+
+# Not using automake
 inherit autotools-brokensep
+CLEANBROKEN = "1"
 
-export DESTDIR = "${D}"
-DEPENDS_class-native = "docbook-xml-dtd4-native"
-RDEPENDS_${PN} += "python" 
-BBCLASSEXTEND = "native"
+# target and nativesdk needs python3, but for native we can use the host.
+RDEPENDS_${PN} += "python3"
+RDEPENDS_remove_class-native = "python3"
 
-CLEANBROKEN = "1"
+BBCLASSEXTEND = "native nativesdk"