]> code.ossystems Code Review - openembedded-core.git/commitdiff
chkconfig: add link files install_initd and remove_initd
authorKang Kai <kai.kang@windriver.com>
Wed, 21 Nov 2012 09:38:43 +0000 (17:38 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 6 Dec 2012 12:30:31 +0000 (12:30 +0000)
Add link files ${libdir}/lsb/{install,remove}_initd that they are
required by LSB tests. They were created by package lsbsetup, but
lsbsetup was dropped, so create them in chkconfig.

Signed-off-by: Kang Kai <kai.kang@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb

index 0f6398f57ed0f5987dc1b3ab8d8dc9d182ac31c3..fd7bd1a1116ca218a94dd639bc4b2ff3a9038372 100644 (file)
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
 
 DEPENDS = "libnewt popt"
 
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "http://fedorahosted.org/releases/c/h/chkconfig/${BPN}-${PV}.tar.bz2"
 
@@ -30,3 +30,11 @@ do_install_append() {
     mkdir -p ${D}${sysconfdir}/chkconfig.d
     rm -f ${D}${sbindir}/update-alternatives
 }
+
+do_install_append_linuxstdbase() {
+       install -d ${D}${libdir}/lsb/
+       ln -sf ${base_sbindir}/chkconfig ${D}/${libdir}/lsb/install_initd
+       ln -sf ${base_sbindir}/chkconfig ${D}/${libdir}/lsb/remove_initd
+}
+
+FILES_${PN}_append_linuxstdbase += "${libdir}/lsb"