]> code.ossystems Code Review - openembedded-core.git/commitdiff
mtd-utils: update to git HEAD
authorMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 9 Apr 2008 15:04:39 +0000 (15:04 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 9 Apr 2008 15:04:39 +0000 (15:04 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4221 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/mtd/mtd-utils-native_1.0.0.bb [deleted file]
meta/packages/mtd/mtd-utils-native_1.1.0+git.bb [moved from meta/packages/mtd/mtd-utils-native_1.0.0+git.bb with 100% similarity]
meta/packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2-git.patch
meta/packages/mtd/mtd-utils/remove-ubi.patch [new file with mode: 0644]
meta/packages/mtd/mtd-utils_1.0.0.bb [deleted file]
meta/packages/mtd/mtd-utils_1.1.0+git.bb [moved from meta/packages/mtd/mtd-utils_1.0.0+git.bb with 76% similarity]

diff --git a/meta/packages/mtd/mtd-utils-native_1.0.0.bb b/meta/packages/mtd/mtd-utils-native_1.0.0.bb
deleted file mode 100644 (file)
index 6f9d71e..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-require mtd-utils_${PV}.bb
-require mtd-utils-native.inc
index 5504a11e8a83ab6588fa3b61073d7a13942c777c..2789fcc531a66cb109e382762d3765dfae75f87a 100644 (file)
@@ -1,26 +1,29 @@
 ---
- mkfs.jffs2.c |   45 ++++++++++++++++++++++++++++++++++++++++++---
- 1 file changed, 42 insertions(+), 3 deletions(-)
+ mkfs.jffs2.c |   44 ++++++++++++++++++++++++++++++++++++++++++--
+ 1 file changed, 42 insertions(+), 2 deletions(-)
 
-Index: git/mkfs.jffs2.c
-===================================================================
---- git.orig/mkfs.jffs2.c      2007-01-23 15:42:34.000000000 +0000
-+++ git/mkfs.jffs2.c   2007-01-23 15:46:08.000000000 +0000
-@@ -97,7 +97,12 @@ struct filesystem_entry {
+--- git.orig/mkfs.jffs2.c
++++ git/mkfs.jffs2.c
+@@ -98,10 +98,16 @@ struct filesystem_entry {
+       struct filesystem_entry *next;  /* Only relevant to non-directories */
        struct filesystem_entry *files; /* Only relevant to directories */
+       struct rb_node hardlink_rb;
  };
  
--
 +struct ignorepath_entry {
 +      struct ignorepath_entry* next;  /* Points to the next ignorepath element */
 +      char name[PATH_MAX];            /* Name of the entry */
 +};
-+ 
++
 +static struct ignorepath_entry* ignorepath = 0;
+ struct rb_root hardlinks;
  static int out_fd = -1;
  static int in_fd = -1;
  static char default_rootdir[] = ".";
-@@ -372,7 +377,7 @@ static struct filesystem_entry *recursiv
+ static char *rootdir = default_rootdir;
+@@ -404,19 +410,28 @@ static struct filesystem_entry *recursiv
+       int i, n;
+       struct stat sb;
        char *hpath, *tpath;
        struct dirent *dp, **namelist;
        struct filesystem_entry *entry;
@@ -29,7 +32,8 @@ Index: git/mkfs.jffs2.c
  
        if (lstat(hostpath, &sb)) {
                perror_msg_and_die("%s", hostpath);
-@@ -381,6 +386,15 @@ static struct filesystem_entry *recursiv
+       }
        entry = add_host_filesystem_entry(targetpath, hostpath,
                        sb.st_uid, sb.st_gid, sb.st_mode, 0, parent);
  
@@ -45,7 +49,11 @@ Index: git/mkfs.jffs2.c
        n = scandir(hostpath, &namelist, 0, alphasort);
        if (n < 0) {
                perror_msg_and_die("opening directory %s", hostpath);
-@@ -1405,6 +1419,7 @@ static struct option long_options[] = {
+       }
+@@ -1446,10 +1461,11 @@ static void create_target_filesystem(str
+ static struct option long_options[] = {
+       {"pad", 2, NULL, 'p'},
        {"root", 1, NULL, 'r'},
        {"pagesize", 1, NULL, 's'},
        {"eraseblock", 1, NULL, 'e'},
@@ -53,7 +61,11 @@ Index: git/mkfs.jffs2.c
        {"output", 1, NULL, 'o'},
        {"help", 0, NULL, 'h'},
        {"verbose", 0, NULL, 'v'},
-@@ -1452,6 +1467,7 @@ static char *helptext =
+       {"version", 0, NULL, 'V'},
+       {"big-endian", 0, NULL, 'b'},
+@@ -1493,10 +1509,11 @@ static char *helptext =
+ "  -y, --compressor-priority=PRIORITY:COMPRESSOR_NAME\n"
+ "                          Set the priority of a compressor\n"
  "  -L, --list-compressors  Show the list of the avaiable compressors\n"
  "  -t, --test-compression  Call decompress and compare with the original (for test)\n"
  "  -n, --no-cleanmarkers   Don't add a cleanmarker to every eraseblock\n"
@@ -61,22 +73,36 @@ Index: git/mkfs.jffs2.c
  "  -o, --output=FILE       Output to FILE (default: stdout)\n"
  "  -l, --little-endian     Create a little-endian filesystem\n"
  "  -b, --big-endian        Create a big-endian filesystem\n"
-@@ -1617,11 +1633,12 @@ int main(int argc, char **argv)
+ "  -D, --devtable=FILE     Use the named FILE as a device table file\n"
+ "  -f, --faketime          Change all file times to '0' for regression testing\n"
+@@ -1659,21 +1676,22 @@ int main(int argc, char **argv)
+       FILE *devtable = NULL;
        struct filesystem_entry *root;
        char *compr_name = NULL;
        int compr_prior  = -1;
-+      struct ignorepath_entry* element = ignorepath;
+       int warn_page_size = 0;
++      struct ignorepath_entry* element = ignorepath;
  
        jffs2_compressors_init();
  
+       page_size = sysconf(_SC_PAGESIZE);
+       if (page_size < 0) /* System doesn't know so ... */
+               page_size = 4096; /* ... we make an educated guess */
+       if (page_size != 4096)
+               warn_page_size = 1; /* warn user if page size not 4096 */
        while ((opt = getopt_long(argc, argv,
 -                                      "D:d:r:s:o:qUPfh?vVe:lbp::nc:m:x:X:Lty:i:", long_options, &c)) >= 0)
-+                                      "D:d:r:s:I:o:qUPfh?vVe:lbp::nc:m:x:X:Lty:i:", long_options, &c)) >= 0)
++                                      "D:d:r:s:I:o:qUPfh?vVe:lbp::nc:m:x:X:Lty:i:", long_options, &c)) >= 0)
        {
                switch (opt) {
                        case 'D':
-@@ -1644,6 +1661,28 @@ int main(int argc, char **argv)
+                               devtable = xfopen(optarg, "r");
+                               if (fstat(fileno(devtable), &sb) < 0)
+@@ -1693,10 +1711,32 @@ int main(int argc, char **argv)
+                       case 's':
                                page_size = strtol(optarg, NULL, 0);
+                               warn_page_size = 0; /* set by user, so don't need to warn */
                                break;
  
 +                      case 'I':
@@ -104,3 +130,5 @@ Index: git/mkfs.jffs2.c
                        case 'o':
                                if (out_fd != -1) {
                                        error_msg_and_die("output filename specified more than once");
+                               }
+                               out_fd = open(optarg, O_CREAT | O_TRUNC | O_RDWR, 0644);
diff --git a/meta/packages/mtd/mtd-utils/remove-ubi.patch b/meta/packages/mtd/mtd-utils/remove-ubi.patch
new file mode 100644 (file)
index 0000000..a788fd0
--- /dev/null
@@ -0,0 +1,33 @@
+---
+ Makefile |    3 ---
+ 1 file changed, 3 deletions(-)
+
+--- git.orig/Makefile
++++ git/Makefile
+@@ -41,19 +41,17 @@ $(BUILDDIR)/%.o: %.c
+       $(CC) $(CFLAGS) -g -c -o $@ $< -g -Wp,-MD,$(BUILDDIR)/.$(<F).dep
+ .SUFFIXES:
+ all: $(TARGETS)
+-      make -C $(BUILDDIR)/ubi-utils
+ IGNORE=${wildcard $(BUILDDIR)/.*.c.dep}
+ -include ${IGNORE}
+ clean:
+       rm -f $(BUILDDIR)/*.o $(TARGETS) $(BUILDDIR)/.*.c.dep $(SYMLINKS)
+       if [ "$(BUILDDIR)x" != ".x" ]; then rm -rf $(BUILDDIR); fi
+-      make -C $(BUILDDIR)/ubi-utils clean
+ $(SYMLINKS):
+       ln -sf ../fs/jffs2/$@ $@
+ $(BUILDDIR)/mkfs.jffs2: $(BUILDDIR)/crc32.o \
+@@ -91,6 +89,5 @@ $(BUILDDIR)/fectest: $(BUILDDIR)/fectest
+ install: ${TARGETS}
+       mkdir -p ${DESTDIR}/${SBINDIR}
+       install -m0755 ${TARGETS} ${DESTDIR}/${SBINDIR}/
+       mkdir -p ${DESTDIR}/${MANDIR}/man1
+       gzip -c mkfs.jffs2.1 > ${DESTDIR}/${MANDIR}/man1/mkfs.jffs2.1.gz
+-      make -C $(BUILDDIR)/ubi-utils install
diff --git a/meta/packages/mtd/mtd-utils_1.0.0.bb b/meta/packages/mtd/mtd-utils_1.0.0.bb
deleted file mode 100644 (file)
index 9c49329..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-DESCRIPTION = "Tools for managing memory technology devices."
-SECTION = "base"
-DEPENDS = "zlib"
-HOMEPAGE = "http://www.linux-mtd.infradead.org/"
-LICENSE = "GPLv2"
-PR = "r1"
-
-# RP/kergoth: Builds seem to break with recent mtd-utils
-# Can't pin down the exact problems
-DEFAULT_PREFERENCE = "-1"
-
-SRC_URI = "ftp://ftp.infradead.org/pub/mtd-utils/mtd-utils-1.0.0.tar.gz"
-S = "${WORKDIR}/mtd-utils-${PV}"
-
-CFLAGS_prepend = "-I${WORKDIR}/mtd-utils-${PV}/include "
-
-do_install() {
-       oe_runmake install DESTDIR=${D}
-}
similarity index 76%
rename from meta/packages/mtd/mtd-utils_1.0.0+git.bb
rename to meta/packages/mtd/mtd-utils_1.1.0+git.bb
index 81eaefad74e366ed5405b15b21f050c6bd539647..ce1477ee70a54e69248dfde0be7b9e8f68302708 100644 (file)
@@ -3,10 +3,10 @@ SECTION = "base"
 DEPENDS = "zlib lzo"
 HOMEPAGE = "http://www.linux-mtd.infradead.org/"
 LICENSE = "GPLv2"
-PR = "r6"
 
-SRC_URI = "git://git.infradead.org/mtd-utils.git;protocol=git;tag=2a032bca585e27ceb0f293905718b416bc297ce2 \
+SRC_URI = "git://git.infradead.org/mtd-utils.git;protocol=git;tag=e6088d987c545d60a86e1f44836ab8ba072fffd9 \
            file://add-exclusion-to-mkfs-jffs2-git.patch;patch=1 \
+          file://remove-ubi.patch;patch=1 \
           file://fix-ignoreerrors-git.patch;patch=1"
 
 S = "${WORKDIR}/git/"
@@ -24,12 +24,11 @@ do_stage () {
 }
 
 mtd_utils = "ftl_format flash_erase flash_eraseall nanddump doc_loadbios \
-             mkfs.jffs ftl_check mkfs.jffs2 flash_lock flash_unlock flash_info mtd_debug \
+             ftl_check mkfs.jffs2 flash_lock flash_unlock flash_info mtd_debug \
              flashcp nandwrite jffs2dump sumtool"
 
 do_install () {
-       install -d ${D}${bindir}
-       for binary in ${mtd_utils}; do
-               install -m 0755 $binary ${D}${bindir}
-       done
+       oe_runmake install DESTDIR=${D}
 }
+
+PARALLEL_MAKE = ""