]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-rp: add no-SCR-check patch to 2.6.23
authorMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 17 Oct 2007 09:03:49 +0000 (09:03 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 17 Oct 2007 09:03:49 +0000 (09:03 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2895 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/linux/linux-rp-2.6.23/mmcsd_no_scr_check-r2.patch [new file with mode: 0644]
meta/packages/linux/linux-rp_2.6.23.bb

diff --git a/meta/packages/linux/linux-rp-2.6.23/mmcsd_no_scr_check-r2.patch b/meta/packages/linux/linux-rp-2.6.23/mmcsd_no_scr_check-r2.patch
new file mode 100644 (file)
index 0000000..ac2245f
--- /dev/null
@@ -0,0 +1,29 @@
+---
+ drivers/mmc/core/sd.c |   11 ++++++-----
+ 1 file changed, 6 insertions(+), 5 deletions(-)
+
+Index: linux-2.6.23/drivers/mmc/core/sd.c
+===================================================================
+--- linux-2.6.23.orig/drivers/mmc/core/sd.c    2007-10-17 11:33:26.000000000 +0200
++++ linux-2.6.23/drivers/mmc/core/sd.c 2007-10-17 11:33:49.000000000 +0200
+@@ -173,14 +173,15 @@
+       scr_struct = UNSTUFF_BITS(resp, 60, 4);
+       if (scr_struct != 0) {
+-              printk(KERN_ERR "%s: unrecognised SCR structure version %d\n",
++              printk(KERN_WARNING "%s: unrecognised SCR structure version %d\n",
+                       mmc_hostname(card->host), scr_struct);
+-              return -EINVAL;
++              scr->sda_vsn = 0;
++              scr->bus_widths = 0;
++      } else {
++              scr->sda_vsn = UNSTUFF_BITS(resp, 56, 4);
++              scr->bus_widths = UNSTUFF_BITS(resp, 48, 4);
+       }
+-      scr->sda_vsn = UNSTUFF_BITS(resp, 56, 4);
+-      scr->bus_widths = UNSTUFF_BITS(resp, 48, 4);
+-
+       return 0;
+ }
index e55bc63d658fc040caf0de9fd2807a59a6f83af5..6dd46e16cb48bb550b394768d78a3f70374f24e5 100644 (file)
@@ -1,6 +1,6 @@
 require linux-rp.inc
 
-PR = "r2"
+PR = "r3"
 
 DEFAULT_PREFERENCE_qemuarm = "-1"
 DEFAULT_PREFERENCE_qemux86 = "-1"
@@ -45,6 +45,7 @@ SRC_URI = "http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.23.tar.bz2 \
            ${RPSRC}/logo_oz-r2.patch.bz2;patch=1;status=unmergable \
            ${RPSRC}/pxa-linking-bug.patch;patch=1;status=unmergable \
            ${RPSRC}/mmcsd_large_cards-r1.patch;patch=1;status=hack \
+           file://mmcsd_no_scr_check-r2.patch;patch=1 \
            ${RPSRC}/integrator_rgb-r1.patch;patch=1;status=hack \
            ${RPSRC}/pxa_cf_initorder_hack-r1.patch;patch=1;status=hack \
            file://pxa-serial-hack.patch;patch=1;status=hack \