]> code.ossystems Code Review - openembedded-core.git/commitdiff
intltool: Adds gettext as a DEPENDS
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>
Tue, 23 May 2017 23:47:42 +0000 (16:47 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 25 May 2017 22:57:01 +0000 (23:57 +0100)
When setting USE_NLS="no" and building systemd-boot
(which DEPENDS on intltool), configure fails,
complaining about missing gettext:

configure: error: GNU gettext tools not found; required for intltool

This is caused because USE_NLS="no" makes the gettext class
add gettext-minimal-native to BASEDEPENDS instead of adding
gettext-native.

Since we still would like to set USE_NLS="no" and build systemd-boot,
we add gettext-native as a dependency to intltool-native, which makes it
available for the configure script of systemd-boot fixing the problem.

[YOCTO #11562]

Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/intltool/intltool_0.51.0.bb

index 551bdf0619a24a87df950e59348dce9fffcdcb2d..ecff2faf253314cd0c4a0b5791671813833c7a06 100644 (file)
@@ -16,7 +16,7 @@ UPSTREAM_CHECK_URI = "https://launchpad.net/intltool/trunk/"
 
 DEPENDS = "libxml-parser-perl-native"
 RDEPENDS_${PN} = "gettext-dev libxml-parser-perl"
-DEPENDS_class-native = "libxml-parser-perl-native"
+DEPENDS_class-native = "libxml-parser-perl-native gettext-native"
 
 inherit autotools pkgconfig perlnative