]> code.ossystems Code Review - openembedded-core.git/commitdiff
ltp: add periodic output for memcg stress test
authorTudor Florea <tudor.florea@enea.com>
Fri, 1 Apr 2016 11:46:19 +0000 (13:46 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 1 Apr 2016 14:02:21 +0000 (15:02 +0100)
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/ltp/ltp/0034-periodic_output.patch [new file with mode: 0644]
meta/recipes-extended/ltp/ltp_20160126.bb

diff --git a/meta/recipes-extended/ltp/ltp/0034-periodic_output.patch b/meta/recipes-extended/ltp/ltp/0034-periodic_output.patch
new file mode 100644 (file)
index 0000000..59caefe
--- /dev/null
@@ -0,0 +1,43 @@
+Add periodic output for long time test.
+
+This is needed in context of having scripts running ltp tests and
+waiting with a timeout for the output of the tests.
+
+Signed-off-by: Tudor Florea <tudor.florea@enea.com>
+Upstream-Status: Pending
+
+diff -ruN a/testcases/kernel/controllers/memcg/stress/memcg_stress_test.sh b/testcases/kernel/controllers/memcg/stress/memcg_stress_test.sh
+--- a/testcases/kernel/controllers/memcg/stress/memcg_stress_test.sh   2013-11-08 15:54:09.515049081 +0100
++++ b/testcases/kernel/controllers/memcg/stress/memcg_stress_test.sh   2013-11-08 22:32:15.587370406 +0100
+@@ -37,7 +37,8 @@
+         exit 0
+ fi
+-RUN_TIME=$(( 60 * 60 ))
++ONE_MINUTE=60
++RUN_TIME=60
+ cleanup()
+ {
+@@ -62,7 +63,7 @@
+ # $1 - Number of cgroups
+ # $2 - Allocated how much memory in one process? in MB
+ # $3 - The interval to touch memory in a process
+-# $4 - How long does this test run ? in second
++# $4 - How long does this test run ? in minutes
+ run_stress()
+ {
+       do_mount;
+@@ -81,7 +82,11 @@
+               eval /bin/kill -s SIGUSR1 \$pid$i 2> /dev/null
+       done
+-      sleep $4
++      for i in $(seq 0 $(($4-1)))
++      do
++              eval echo "Started $i min ago. Still alive... " 
++              sleep $ONE_MINUTE
++      done
+       for i in $(seq 0 $(($1-1)))
+       do
index 720a569ae52750443f0fefc45f5c834156c3cb62..6be2187eaa0a26d3a91858d7b5ed29186e2daddc 100644 (file)
@@ -60,6 +60,7 @@ SRC_URI = "git://github.com/linux-test-project/ltp.git \
            file://0031-vma03-fix-page-size-offset-as-per-page-size-alignmen.patch \
            file://0032-regen.sh-Include-asm-unistd.h-explicitly.patch \
            file://0033-shmat1-Cover-GNU-specific-code-under-__USE_GNU.patch \
+           file://0034-periodic_output.patch \
            "
 
 S = "${WORKDIR}/git"