]> code.ossystems Code Review - openembedded-core.git/commitdiff
grub-efi: Deploy grub named efi binaries
authorSaul Wold <sgw@linux.intel.com>
Tue, 24 Jan 2017 21:33:15 +0000 (13:33 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 31 Jan 2017 14:40:19 +0000 (14:40 +0000)
This allows both grub and systemd-boot efi bootloaders to co-exisit

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-bsp/grub/grub-efi_2.00.bb

index 03d273dbd943821c6080d1c1a2b1a69e46bee717..e0503013fd733e5feb81230b933ffd38b4e54fb6 100644 (file)
@@ -16,10 +16,10 @@ python __anonymous () {
     target = d.getVar('TARGET_ARCH')
     if target == "x86_64":
         grubtarget = 'x86_64'
-        grubimage = "bootx64.efi"
+        grubimage = "grub-efi-bootx64.efi"
     elif re.match('i.86', target):
         grubtarget = 'i386'
-        grubimage = "bootia32.efi"
+        grubimage = "grub-efi-bootia32.efi"
     else:
         raise bb.parse.SkipPackage("grub-efi is incompatible with target %s" % target)
     d.setVar("GRUB_TARGET", grubtarget)