]> code.ossystems Code Review - openembedded-core.git/commitdiff
weston: upgrade to 1.4.0
authorValentin Popa <valentin.popa@intel.com>
Thu, 13 Feb 2014 13:45:20 +0000 (15:45 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 17 Feb 2014 15:27:56 +0000 (15:27 +0000)
(*) added fbdev backend in case the user will
    want to use weston even if drm fails.
(*) removed tablet-shell flag because in 1.4
    tablet-shell has been removed from src.
(*) tested on qemux86 and genericx86 with
    core-image-weston and core-image-sato.

Signed-off-by: Valentin Popa <valentin.popa@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-graphics/wayland/weston/0001-remove-dependence-on-wayland-scanner-flags.patch [new file with mode: 0644]
meta/recipes-graphics/wayland/weston_1.4.0.bb [moved from meta/recipes-graphics/wayland/weston_1.3.1.bb with 89% similarity]

diff --git a/meta/recipes-graphics/wayland/weston/0001-remove-dependence-on-wayland-scanner-flags.patch b/meta/recipes-graphics/wayland/weston/0001-remove-dependence-on-wayland-scanner-flags.patch
new file mode 100644 (file)
index 0000000..14606c8
--- /dev/null
@@ -0,0 +1,30 @@
+From a0335393ddde2228c84eda1081b5d7b175f78a94 Mon Sep 17 00:00:00 2001
+From: Valentin Popa <valentin.popa@intel.com>
+Date: Fri, 7 Feb 2014 16:59:58 +0200
+Subject: [PATCH] remove dependence on wayland-scanner flags
+
+weston doesn't make use of wayland-scanner flags,
+it only uses the -native- wayland-scanner for protocol.
+
+Upstream-Status: Pending
+Signed-off-by: Valentin Popa <valentin.popa@intel.com>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index cce1850..8775eb9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -482,7 +482,7 @@ if test x$wayland_scanner = x; then
+       AC_MSG_ERROR([wayland-scanner is needed to compile weston])
+ fi
+-PKG_CHECK_MODULES(WAYLAND_SCANNER, wayland-scanner)
++#PKG_CHECK_MODULES(WAYLAND_SCANNER, wayland-scanner)
+ AC_PATH_PROG(XMLLINT, xmllint)
+ AC_ARG_WITH([dtddir],
+           AS_HELP_STRING([--with-dtddir],
+-- 
+1.8.3.2
+
similarity index 89%
rename from meta/recipes-graphics/wayland/weston_1.3.1.bb
rename to meta/recipes-graphics/wayland/weston_1.4.0.bb
index 585de66261a2e9a7dd8e3818d6d9df95bed61575..5c389a0e0410ce1faba9b9a9d4bc36bb6ceb7948 100644 (file)
@@ -7,9 +7,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=275efac2559a224527bd4fd593d38466 \
 
 SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
            file://weston.png \
-           file://weston.desktop"
-SRC_URI[md5sum] = "ffe7c3bc0e7eb39a305cbbea8c7766f3"
-SRC_URI[sha256sum] = "f7141334b141ae1a6435bd03bfdb01b7fb628f39259164f201e7e71c8d815bc7"
+           file://weston.desktop \
+           file://0001-remove-dependence-on-wayland-scanner-flags.patch"
+SRC_URI[md5sum] = "4438d2b1f3c9ba9a4a2b10d89fac6fd0"
+SRC_URI[sha256sum] = "74a2319d98e9cdb1acf24659699719aa89ac268cf549759271e326edc5f9ed64"
 
 
 inherit autotools pkgconfig useradd
@@ -18,18 +19,17 @@ DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg"
 DEPENDS += "wayland virtual/egl pango"
 
 EXTRA_OECONF = "--enable-setuid-install \
-                --disable-tablet-shell \
                 --disable-xwayland \
                 --enable-simple-clients \
                 --enable-clients \
-                --enable-demo-clients \
+                --enable-demo-clients-install \
                 --disable-simple-egl-clients \
                 --disable-libunwind \
                 --disable-rpi-compositor \
                 --disable-rdp-compositor"
 
 
-PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'wayland', 'kms wayland', '', d)} \
+PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'wayland', 'kms fbdev wayland', '', d)} \
                    ${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
                    ${@base_contains('DISTRO_FEATURES', 'pam', 'launch', '', d)} \
                   "