]> code.ossystems Code Review - openembedded-core.git/commitdiff
xev: upgraded to 1.0.3
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 28 Mar 2008 15:32:15 +0000 (15:32 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 28 Mar 2008 15:32:15 +0000 (15:32 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4133 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/xorg-app/xev-1.0.2/diet-x11.patch [deleted file]
meta/packages/xorg-app/xev/diet-x11.patch
meta/packages/xorg-app/xev_1.0.3.bb [moved from meta/packages/xorg-app/xev_1.0.2.bb with 100% similarity]

diff --git a/meta/packages/xorg-app/xev-1.0.2/diet-x11.patch b/meta/packages/xorg-app/xev-1.0.2/diet-x11.patch
deleted file mode 100644 (file)
index 9f515e8..0000000
+++ /dev/null
@@ -1,80 +0,0 @@
----
- xev.c |   16 ++++++++--------
- 1 file changed, 8 insertions(+), 8 deletions(-)
-
-Index: xev-1.0.2/xev.c
-===================================================================
---- xev-1.0.2.orig/xev.c       2006-06-02 00:25:44.000000000 +0100
-+++ xev-1.0.2/xev.c    2007-05-10 15:22:07.000000000 +0100
-@@ -109,7 +109,7 @@ do_KeyPress (XEvent *eventp)
-     nbytes = XLookupString (e, str, 256, &ks, NULL);
-     /* not supposed to call XmbLookupString on a key release event */
--    if (e->type == KeyPress && xic) {
-+    /*if (e->type == KeyPress && xic) {
-         do {
-             nmbbytes = XmbLookupString (xic, e, buf, bsize - 1, &ks, &status);
-             buf[nmbbytes] = '\0';
-@@ -119,7 +119,7 @@ do_KeyPress (XEvent *eventp)
-                 buf = realloc (buf, bsize);
-             }
-         } while (status == XBufferOverflow);
--    }
-+    }*/
-     if (ks == NoSymbol)
-       ksname = "NoSymbol";
-@@ -149,7 +149,7 @@ do_KeyPress (XEvent *eventp)
-     }
-     /* not supposed to call XmbLookupString on a key release event */
--    if (e->type == KeyPress && xic) {
-+    /*if (e->type == KeyPress && xic) {
-         printf ("    XmbLookupString gives %d bytes: ", nmbbytes);
-         if (nmbbytes > 0) {
-            dump (buf, nmbbytes);
-@@ -157,7 +157,7 @@ do_KeyPress (XEvent *eventp)
-         } else {
-          printf ("\n");
-         }
--    }
-+    } */
-     printf ("    XFilterEvent returns: %s\n", 
-           XFilterEvent (eventp, e->window) ? "True" : "False");
-@@ -804,7 +804,7 @@ main (int argc, char **argv)
-         fprintf (stderr, "%s:  XSetLocaleModifiers failed\n", ProgramName);
-     }
--    xim = XOpenIM (dpy, NULL, NULL, NULL);
-+    /*xim = XOpenIM (dpy, NULL, NULL, NULL);
-     if (xim == NULL) {
-         fprintf (stderr, "%s:  XOpenIM failed\n", ProgramName);
-     }
-@@ -831,7 +831,7 @@ main (int argc, char **argv)
-             }
-             XFree (xim_styles);
-         }
--    } 
-+    }*/
-     screen = DefaultScreen (dpy);
-@@ -891,7 +891,7 @@ main (int argc, char **argv)
-       printf ("Outer window is 0x%lx, inner window is 0x%lx\n", w, subw);
-     }
--    if (xim && xim_style) {
-+    /*if (xim && xim_style) {
-         xic = XCreateIC (xim, 
-                          XNInputStyle, xim_style, 
-                          XNClientWindow, w, 
-@@ -901,7 +901,7 @@ main (int argc, char **argv)
-         if (xic == NULL) {
-             fprintf (stderr, "XCreateIC failed\n");
-         }
--    }
-+    }*/
-     for (done = 0; !done; ) {
-       XEvent event;
index 7e93f160a5a758cb548ba85fc4411bd465cd2194..9f515e8c73c316c0f804133fe27279a7d0134bde 100644 (file)
@@ -1,6 +1,12 @@
---- xev/xev.c  2004-02-06 11:00:37.000000000 -0800
-+++ xev/xev.new.c      2005-08-04 15:40:36.000000000 -0700
-@@ -149,7 +149,7 @@
+---
+ xev.c |   16 ++++++++--------
+ 1 file changed, 8 insertions(+), 8 deletions(-)
+
+Index: xev-1.0.2/xev.c
+===================================================================
+--- xev-1.0.2.orig/xev.c       2006-06-02 00:25:44.000000000 +0100
++++ xev-1.0.2/xev.c    2007-05-10 15:22:07.000000000 +0100
+@@ -109,7 +109,7 @@ do_KeyPress (XEvent *eventp)
      nbytes = XLookupString (e, str, 256, &ks, NULL);
  
      /* not supposed to call XmbLookupString on a key release event */
@@ -9,7 +15,7 @@
          do {
              nmbbytes = XmbLookupString (xic, e, buf, bsize - 1, &ks, &status);
              buf[nmbbytes] = '\0';
-@@ -159,7 +159,7 @@
+@@ -119,7 +119,7 @@ do_KeyPress (XEvent *eventp)
                  buf = realloc (buf, bsize);
              }
          } while (status == XBufferOverflow);
@@ -18,7 +24,7 @@
  
      if (ks == NoSymbol)
        ksname = "NoSymbol";
-@@ -189,7 +189,7 @@
+@@ -149,7 +149,7 @@ do_KeyPress (XEvent *eventp)
      }
  
      /* not supposed to call XmbLookupString on a key release event */
          printf ("    XmbLookupString gives %d bytes: ", nmbbytes);
          if (nmbbytes > 0) {
             dump (buf, nmbbytes);
-@@ -200,7 +200,7 @@
-         printf ("    XFilterEvent returns: %s\n", 
-                 XFilterEvent (eventp, e->window) ? "True" : "False");
+@@ -157,7 +157,7 @@ do_KeyPress (XEvent *eventp)
+         } else {
+          printf ("\n");
+         }
 -    }
-+    }*/
- }
++    } */
  
- static void
-@@ -857,7 +857,7 @@
+     printf ("    XFilterEvent returns: %s\n", 
+           XFilterEvent (eventp, e->window) ? "True" : "False");
+@@ -804,7 +804,7 @@ main (int argc, char **argv)
          fprintf (stderr, "%s:  XSetLocaleModifiers failed\n", ProgramName);
      }
  
@@ -45,7 +51,7 @@
      if (xim == NULL) {
          fprintf (stderr, "%s:  XOpenIM failed\n", ProgramName);
      }
-@@ -884,7 +884,7 @@
+@@ -831,7 +831,7 @@ main (int argc, char **argv)
              }
              XFree (xim_styles);
          }
@@ -54,7 +60,7 @@
  
      screen = DefaultScreen (dpy);
  
-@@ -948,7 +948,7 @@
+@@ -891,7 +891,7 @@ main (int argc, char **argv)
        printf ("Outer window is 0x%lx, inner window is 0x%lx\n", w, subw);
      }
  
@@ -63,7 +69,7 @@
          xic = XCreateIC (xim, 
                           XNInputStyle, xim_style, 
                           XNClientWindow, w, 
-@@ -958,7 +958,7 @@
+@@ -901,7 +901,7 @@ main (int argc, char **argv)
          if (xic == NULL) {
              fprintf (stderr, "XCreateIC failed\n");
          }