]> code.ossystems Code Review - openembedded-core.git/commitdiff
librsvg: update gdk-pixbuf loader cache when staging native package
authorTomas Frydrych <tomas@sleepfive.com>
Fri, 10 May 2013 13:36:39 +0000 (14:36 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 12 May 2013 07:35:16 +0000 (08:35 +0100)
librsvg installs an svg loader for gdk-pixbuf; in order for the native version
of the loader to be usable by gdk-pixbuf-native we have to update the loader
cache.

Signed-off-by: Tomas Frydrych <tomas@sleepfive.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-gnome/librsvg/librsvg_2.32.1.bb

index ff17cf75ed0ef9104f948613d7c6835fcbad394a..dcacce4b0078e0550c6d74ca0ea02d98e53e77f3 100644 (file)
@@ -55,3 +55,14 @@ FILES_librsvg-gtk-dbg += "${libdir}/gdk-pixbuf-2.0/.debug \
 
 PIXBUF_PACKAGES = "librsvg-gtk"
 PARALLEL_MAKE = ""
+
+# ensure that the native gdk-pixbuf loaders cache is updated when we stage
+# our svg loader
+SSTATEPOSTINSTFUNCS_class_native += "librsvg_sstate_postinst"
+
+librsvg_sstate_postinst() {
+       if [ "${BB_CURRENTTASK}" = "populate_sysroot" -o "${BB_CURRENTTASK}" = "populate_sysroot_setscene" ]
+       then
+               GDK_PIXBUF_MODULEDIR=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/2.10.0/loaders GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/2.10.0/loaders.cache gdk-pixbuf-query-loaders --update-cache
+       fi
+}