]> code.ossystems Code Review - openembedded-core.git/commitdiff
curl: add debug info
authorRasmus Villemoes <rasmus.villemoes@prevas.dk>
Wed, 17 Jun 2020 08:52:14 +0000 (10:52 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 17 Jun 2020 15:31:48 +0000 (16:31 +0100)
Currently, curl (and libcurl) is built without debug info, making the
curl-dbg package rather useless. Since debug symbols are automatically
stripped and put in that package by the build system, making sure that
curl is built with -g shouldn't hurt anything, but will help those
that try to debug a libcurl-using application and hence explicitly
include curl-dbg in their rootfs.

Unfortunately, setting --enable-debug then changes the default value
of the optimize option from (assume yes) to (assume no), while also
changing the default value of the curldebug option [which is a
separate thing that actually changes generated code to add some memory
tracking] from (assume no) to (assume yes). So explicitly pass the
appropriate options that make those two have the same value as they
used to have by default.

Signed-off-by: Rasmus Villemoes <rasmus.villemoes@prevas.dk>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/curl/curl_7.70.0.bb

index baf72f8e757951c2d8e6716500348a40ee089f32..bb25677ef701da0f5096c70692cd1be6dc00289f 100644 (file)
@@ -57,6 +57,9 @@ EXTRA_OECONF = " \
     --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
     --without-libmetalink \
     --without-libpsl \
+    --enable-debug \
+    --enable-optimize \
+    --disable-curldebug \
 "
 
 do_install_append_class-target() {