]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxslt: fix CVE-2019-18197
authorJoe Slater <joe.slater@windriver.com>
Wed, 6 Nov 2019 18:45:54 +0000 (10:45 -0800)
committerArmin Kuster <akuster808@gmail.com>
Sun, 10 Nov 2019 21:54:34 +0000 (13:54 -0800)
Use patch from upstream after 1.1.33 release.

Signed-off-by: Joe Slater <joe.slater@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
meta/recipes-support/libxslt/files/CVE-2019-18197.patch [new file with mode: 0644]
meta/recipes-support/libxslt/libxslt_1.1.33.bb

diff --git a/meta/recipes-support/libxslt/files/CVE-2019-18197.patch b/meta/recipes-support/libxslt/files/CVE-2019-18197.patch
new file mode 100644 (file)
index 0000000..5f2b620
--- /dev/null
@@ -0,0 +1,33 @@
+libxslt: fix CVE-2019-18197
+
+Added after 1.1.33 release.
+
+CVE: CVE-2019-18197
+Upstream-Status: Backport [https://gitlab.gnome.org/GNOME/libxslt.git]
+Signed-off-by: Joe Slater <joe.slater@windriver.com>
+
+commit 2232473733b7313d67de8836ea3b29eec6e8e285
+Author: Nick Wellnhofer <wellnhofer@aevum.de>
+Date:   Sat Aug 17 16:51:53 2019 +0200
+
+    Fix dangling pointer in xsltCopyText
+    
+    xsltCopyText didn't reset ctxt->lasttext in some cases which could
+    lead to various memory errors in relation with CDATA sections in input
+    documents.
+    
+    Found by OSS-Fuzz.
+
+diff --git a/libxslt/transform.c b/libxslt/transform.c
+index 95ebd07..d7ab0b6 100644
+--- a/libxslt/transform.c
++++ b/libxslt/transform.c
+@@ -1094,6 +1094,8 @@ xsltCopyText(xsltTransformContextPtr ctxt, xmlNodePtr target,
+           if ((copy->content = xmlStrdup(cur->content)) == NULL)
+               return NULL;
+       }
++
++      ctxt->lasttext = NULL;
+     } else {
+         /*
+        * normal processing. keep counters to extend the text node
index abc00a09ea0a4cec74ea0fef28badf0965d93fdb..9f268e7bb039064d6ad4d427eea842a6b3c8eef7 100644 (file)
@@ -12,6 +12,7 @@ SRC_URI = "http://xmlsoft.org/sources/libxslt-${PV}.tar.gz \
            file://0001-Fix-security-framework-bypass.patch \
            file://CVE-2019-13117.patch \
            file://CVE-2019-13118.patch \
+           file://CVE-2019-18197.patch \
 "
 
 SRC_URI[md5sum] = "b3bd254a03e46d58f8ad1e4559cd2c2f"