]> code.ossystems Code Review - openembedded-core.git/commitdiff
parted: Make readline dependency optional
authorMark Jonas <toertel@gmail.com>
Sat, 12 Dec 2020 15:05:32 +0000 (16:05 +0100)
committerAnuj Mittal <anuj.mittal@intel.com>
Tue, 22 Dec 2020 01:39:02 +0000 (09:39 +0800)
Signed-off-by: Mark Jonas <toertel@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit bb433833d2ae7b87d18dfae5635eac9097ecc9b7)
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
meta/recipes-extended/parted/parted_3.3.bb

index a1fd3ef07bf66c251910926341e7d436d44ebd97..ce40c04ad4b69f3acf5b675d5f104d645cb7ba5c 100644 (file)
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
 LICENSE = "GPLv3+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=2f31b266d3440dd7ee50f92cf67d8e6c"
 SECTION = "console/tools"
-DEPENDS = "ncurses readline util-linux virtual/libiconv"
+DEPENDS = "ncurses util-linux virtual/libiconv"
 
 SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.xz \
            file://no_check.patch \
@@ -22,6 +22,9 @@ EXTRA_OECONF = "--disable-device-mapper"
 
 inherit autotools pkgconfig gettext texinfo ptest
 
+PACKAGECONFIG ?= "readline"
+PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"
+
 BBCLASSEXTEND = "native nativesdk"
 
 do_compile_ptest() {