]> code.ossystems Code Review - openembedded-core.git/commitdiff
uboot: move license data into recipe with SRC_URI
authorDarren Hart <dvhart@linux.intel.com>
Wed, 9 Feb 2011 21:38:53 +0000 (13:38 -0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 9 Feb 2011 22:44:52 +0000 (22:44 +0000)
The LIC_CHKSUM_FILES are specific to the source determined by SRC_URI. As such,
keep all the license information together with the SRC_URI. This also avoids
confusion from having these defined in both the .inc and the .bb files. The
CHKSUM got out of date in u-boot_git.bb, so update it while we're at it.

Signed-off-by: Darren Hart <dvhart@linux.intel.com>
CC: Ilya Yanok <yanok@emcraft.com>
CC: Gary Thomas <gary@mlbassoc.com>
CC: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-bsp/uboot/u-boot.inc
meta/recipes-bsp/uboot/u-boot_git.bb

index f60667ee6bba693b59c1f105710fda93d8d6d9f4..1457c042e8d33c76f763916e08d9cee9222192ef 100644 (file)
@@ -2,11 +2,8 @@ DESCRIPTION = "U-boot bootloader"
 HOMEPAGE = "http://u-boot.sf.net"
 SECTION = "bootloaders"
 PRIORITY = "optional"
-LICENSE = "GPLv2"
 PROVIDES = "virtual/bootloader"
 
-LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
-
 inherit deploy
 
 PARALLEL_MAKE=""
index 16a1dbefaef6b850cbcb6308bcc138f86116b34c..b3207c68b0b92b4692f2929f58d31b5291c3c4de 100644 (file)
@@ -1,7 +1,7 @@
 require u-boot.inc
 
 LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=4c6cde5df68eff615d36789dc18edd3b \
+LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
                     file://README;beginline=1;endline=22;md5=3a00ef51d3fc96e9d6c1bc4708ccd3b5"
 
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/u-boot-git/${MACHINE}"