]> code.ossystems Code Review - openembedded-core.git/commitdiff
gnome-icon-theme: fix build
authorJoshua Lock <josh@linux.intel.com>
Wed, 20 Oct 2010 21:25:22 +0000 (22:25 +0100)
committerJoshua Lock <josh@linux.intel.com>
Wed, 20 Oct 2010 21:30:01 +0000 (22:30 +0100)
Duplicate the patch from sato-icon-theme which enables the path to the
icon-name-mapping tool to be specified.

Signed-off-by: Joshua Lock <josh@linux.intel.com>
meta/recipes-gnome/gnome/gnome-icon-theme/iconpath-option.patch [new file with mode: 0644]
meta/recipes-gnome/gnome/gnome-icon-theme_2.22.0.bb

diff --git a/meta/recipes-gnome/gnome/gnome-icon-theme/iconpath-option.patch b/meta/recipes-gnome/gnome/gnome-icon-theme/iconpath-option.patch
new file mode 100644 (file)
index 0000000..935b358
--- /dev/null
@@ -0,0 +1,51 @@
+Version of the patch of the same name from sato-icon-theme JL - 20/10/10
+"
+pkg-config will only search the target sysroot and we want the native script. This 
+patch adds an option to allow the path to the tool to be specified.
+
+RP - 12/8/10"
+Index: gnome-icon-theme-2.22.0/configure.in
+===================================================================
+--- gnome-icon-theme-2.22.0.orig/configure.in
++++ gnome-icon-theme-2.22.0/configure.in
+@@ -28,20 +28,28 @@ AC_SUBST(themedir, "\${datadir}/icons/gn
+ UTILS_REQUIRED=0.8.1
+-AC_MSG_CHECKING([icon-naming-utils >= $UTILS_REQUIRED])
+-PKG_CHECK_EXISTS(icon-naming-utils >= $UTILS_REQUIRED,
+-                 have_utils=yes, have_utils=no)
+-if test "x$have_utils" = "xyes"; then
+-   UTILS_PATH="`$PKG_CONFIG --variable=program_path icon-naming-utils`"
+-   ICONMAP="$UTILS_PATH/icon-name-mapping"
+-   AC_SUBST(ICONMAP)
+-   AC_MSG_RESULT([yes])
+-else
+-   AC_MSG_RESULT([no])
+-   AC_MSG_ERROR([icon-naming-utils >= $UTILS_REQUIRED is required to build
+-                 and install gnome-icon-theme])
++PKG_PROG_PKG_CONFIG()
++
++AC_ARG_WITH(iconmap,
++          AC_HELP_STRING([--with-iconmap=<dir>], [The location of the icon-name-mapping script to use]),
++          ICONMAP=$withval, ICONMAP="")
++if test "x$ICONMAP" = "x"; then
++   AC_MSG_CHECKING([icon-naming-utils >= $UTILS_REQUIRED])
++   PKG_CHECK_EXISTS(icon-naming-utils >= $UTILS_REQUIRED,
++                  have_utils=yes, have_utils=no)
++   if test "x$have_utils" = "xyes"; then
++      UTILS_PATH="`$PKG_CONFIG --variable=program_path icon-naming-utils`"
++      ICONMAP="$UTILS_PATH/icon-name-mapping"
++
++      AC_MSG_RESULT([yes])
++    else
++      AC_MSG_RESULT([no])
++      AC_MSG_ERROR([icon-naming-utils >= $UTILS_REQUIRED is required to build and install sato-icon-theme"])
++    fi
+ fi
++AC_SUBST(ICONMAP)
++
+ AC_CONFIG_FILES([
+ Makefile
+ gnome-icon-theme.pc
index f78e6a6e5b2ed25dab260cc5655f711b7e85abe3..bdf5ee4fc84912a6762accc050485ea6c69b58b0 100644 (file)
@@ -3,12 +3,15 @@ SECTION = "x11/gnome"
 DEPENDS = "icon-naming-utils-native glib-2.0 intltool-native"
 RDEPENDS = "hicolor-icon-theme"
 RRECOMMENDS = "librsvg-gtk"
-PR = "r1"
+PR = "r2"
 
 FILES_${PN} += "${datadir}/*"
 
-EXTRA_OECONF = "--disable-hicolor-check"
+SRC_URI = "${GNOME_MIRROR}/${PN}/2.22/${PN}-${PV}.tar.bz2 \
+           file://iconpath-option.patch"
 
-inherit gnome
+EXTRA_OECONF = "--disable-hicolor-check --with-iconmap=${STAGING_LIBDIR_NATIVE}/../libexec/icon-name-mapping"
+
+inherit autotools
 
 PACKAGE_ARCH = "all"