]> code.ossystems Code Review - openembedded-core.git/commitdiff
iptables: upgrade to 1.4.12.2
authorShane Wang <shane.wang@intel.com>
Sat, 21 Jan 2012 14:27:32 +0000 (22:27 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 24 Jan 2012 11:23:57 +0000 (11:23 +0000)
This patch is to upgrade iptables to 1.4.12.2, and introduce a patch not to check unknown symbols.
Otherwise, when it is compiled, it will report "libxtables.so.7" from LD_PRELOAD cannot be preloaded.

Signed-off-by: Shane Wang <shane.wang@intel.com>
meta/recipes-extended/iptables/iptables/GNUmakefile.patch [new file with mode: 0644]
meta/recipes-extended/iptables/iptables_1.4.12.2.bb [moved from meta/recipes-extended/iptables/iptables_1.4.12.1.bb with 88% similarity]

diff --git a/meta/recipes-extended/iptables/iptables/GNUmakefile.patch b/meta/recipes-extended/iptables/iptables/GNUmakefile.patch
new file mode 100644 (file)
index 0000000..c60e84f
--- /dev/null
@@ -0,0 +1,18 @@
+Don't check unknown symbols.
+
+Signed-off-by: Shane Wang <shane.wang@intel.com>
+
+Upstream-Status: Inappropriate [configuration]
+
+diff -r abb89394ce0c extensions/GNUmakefile.in
+--- a/extensions/GNUmakefile.in        Mon Jan 23 00:12:27 2012 +0800
++++ b/extensions/GNUmakefile.in        Mon Jan 23 00:38:32 2012 +0800
+@@ -68,7 +68,7 @@
+ .PHONY: all install clean distclean FORCE
+-all: ${targets} check
++all: ${targets}
+ check: ${targets}
+       @echo "  CHECK    unknown symbols in .so files"; \
similarity index 88%
rename from meta/recipes-extended/iptables/iptables_1.4.12.1.bb
rename to meta/recipes-extended/iptables/iptables_1.4.12.2.bb
index 52aa4d52c9d93fb01eee367ae68ce3472845c23b..2d3d3113bbf1883d3f1c58e35368b17265cb88ca 100644 (file)
@@ -21,10 +21,11 @@ RRECOMMENDS_${PN} = "kernel-module-x-tables \
 FILES_${PN} =+ "${libdir}/xtables/"
 FILES_${PN}-dbg =+ "${libdir}/xtables/.debug"
 
-SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.bz2"
+SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.bz2 \
+           file://GNUmakefile.patch"
 
-SRC_URI[md5sum] = "b08a1195ec2c1ebeaf072db3c55fdf43"
-SRC_URI[sha256sum] = "77e6581f21f15946a814fa311236e5f3f7c6593180f9d695cea06aa95e464aba"
+SRC_URI[md5sum] = "212112389c7f10c72efb31a4ed193a4c"
+SRC_URI[sha256sum] = "09fff7dfe6af95675474fd5d0fc67622fac5a0f3d6e02ee614deae9a2e5dae13"
 
 inherit autotools