]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpcbind: Use update-alternatives for rpcinfo
authorKhem Raj <raj.khem@gmail.com>
Tue, 1 Sep 2020 22:32:27 +0000 (15:32 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 5 Sep 2020 21:18:12 +0000 (22:18 +0100)
rpcinfo is also provided vy netkit in meta-networking

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb

index aff00e56e629503cebcb3366bd2482875afd68e2..ec8f9e48b26b50b981abdfd61d959eb8f3247e4e 100644 (file)
@@ -19,7 +19,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/rpcbind/rpcbind-${PV}.tar.bz2 \
 SRC_URI[md5sum] = "ed46f09b9c0fa2d49015f6431bc5ea7b"
 SRC_URI[sha256sum] = "2ce360683963b35c19c43f0ee2c7f18aa5b81ef41c3fdbd15ffcb00b8bffda7a"
 
-inherit autotools update-rc.d systemd pkgconfig
+inherit autotools update-rc.d systemd pkgconfig update-alternatives
 
 PACKAGECONFIG ??= "tcp-wrappers"
 PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
@@ -50,3 +50,6 @@ do_install_append () {
                ${WORKDIR}/init.d > ${D}${sysconfdir}/init.d/rpcbind
        chmod 0755 ${D}${sysconfdir}/init.d/rpcbind
 }
+
+ALTERNATIVE_${PN} = "rpcinfo"
+ALTERNATIVE_LINK_NAME[rpcinfo] = "${bindir}/rpcinfo"