]> code.ossystems Code Review - openembedded-core.git/commitdiff
packagegroup-core-x11-xserver: Add XSERVERCODECS variable
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 24 Jan 2013 05:56:09 +0000 (21:56 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 24 Jan 2013 20:07:59 +0000 (20:07 +0000)
At present its hard for the system to provide extra x11 hardware codecs.
We could lump them in with the XSERVER variable but this is suboptimal as
in some use cases the user might not want to include them in some images.

With this patch we keep our options open about separating usage of the two
in the future.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb

index fd6ed42cbe3ee1ffd2ed4ffe41acd0f87823ef60..3c70c530d9c8e3fb94bcd10ea741c55d1f594e74 100644 (file)
@@ -10,10 +10,12 @@ inherit packagegroup
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 XSERVER ?= "xserver-xorg xf86-video-fbdev xf86-input-evdev"
+XSERVERCODECS ?= ""
 
 SUMMARY_${PN} = "X11 display server"
 RDEPENDS_${PN} = "\
     ${XSERVER} \
+    ${XSERVERCODECS} \
     "
 
 # Allow replacing task-x11-server in meta-oe