]> code.ossystems Code Review - openembedded-core.git/commitdiff
gcc-runtime: Fix dbg files
authorMark Hatle <mark.hatle@windriver.com>
Thu, 10 Mar 2011 23:52:20 +0000 (17:52 -0600)
committerSaul Wold <sgw@linux.intel.com>
Fri, 11 Mar 2011 02:16:07 +0000 (18:16 -0800)
In order to debug certain C++ items, you need the helper python
components.  These components should live in the -dbg package, ensure
they are added to the recipe.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-devtools/gcc/gcc-package-runtime.inc
meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb

index 04c70c0e4fe127da66b2d90b7bb7ce452ebf992a..51483f9980e2c2a830a30898a506150f46ed8175 100644 (file)
@@ -15,6 +15,11 @@ PACKAGES = "\
 # The base package doesn't exist, so we clear the recommends.
 RRECOMMENDS_${PN}-dbg = ""
 
+# include python debugging scripts
+FILES_${PN}-dbg += "\
+  ${libdir}/libstdc++.so.*-gdb.py \
+  ${datadir}/gcc-${PV}/python/libstdcxx"
+
 FILES_libg2c = "${target_libdir}/libg2c.so.*"
 FILES_libg2c-dev = "\
   ${libdir}/libg2c.so \
index c1e680d3c04eff5ae62e6a581302a32306312200..9eb658b12c29697b8b17a6b199299106899299b0 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r3"
+PR = "r4"
 
 require gcc-${PV}.inc
 require gcc-configure-runtime.inc