]> code.ossystems Code Review - openembedded-core.git/commitdiff
removed some utter madness from speex recipe
authorTomas Frydrych <tf@openedhand.com>
Wed, 11 Jul 2007 19:44:10 +0000 (19:44 +0000)
committerTomas Frydrych <tf@openedhand.com>
Wed, 11 Jul 2007 19:44:10 +0000 (19:44 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2170 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/speex/speex_1.1.7.bb

index 4757e275bea885674af9b11923b9e39c61d191fa..624f76287cdac5c8c0499cfbe71f16cabea02915 100644 (file)
@@ -3,7 +3,7 @@ SECTION = "libs"
 LICENSE = "BSD"
 HOMEPAGE = "http://www.speex.org"
 DEPENDS = "libogg"
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "http://downloads.us.xiph.org/releases/speex/${PN}-${PV}.tar.gz"
 
@@ -15,16 +15,10 @@ inherit autotools
 #      --enable-arm5e-asm
 #      --enable-fixed-point
 #
+# NB: the arm assembly is currently broken :(
+#
 
-EXTRA_OECONF_append_openmn = " --enable-arm5e-asm --enable-fixed-point"
-
-do_configure_append() {
-       sed -i s/"^OGG_CFLAGS.*$"/"OGG_CFLAGS = "/g Makefile */Makefile */*/Makefile
-       sed -i s/"^OGG_LIBS.*$"/"OGG_LIBS = -logg"/g Makefile */Makefile */*/Makefile
-       perl -pi -e 's:^includedir.*$:includedir = ${STAGING_INCDIR}:g' Makefile */Makefile */*/Makefile
-       perl -pi -e 's:^oldincludedir.*$:includedir = ${STAGING_INCDIR}:g' Makefile */Makefile */*/Makefile
-       perl -pi -e 's:\s*-I/usr/include$::g' Makefile */Makefile */*/Makefile
-}
+EXTRA_OECONF = " --enable-fixed-point --with-ogg-libraries=${STAGING_LIBDIR} --with-ogg-includes=${STAGING_INCDIR}"
 
 do_stage() {
        oe_libinstall -C libspeex/.libs -so libspeex ${STAGING_LIBDIR}