Index: offscreen/js/ctypes/libffi/configure.ac
===================================================================
---- offscreen.orig/js/ctypes/libffi/configure.ac 2010-02-01 14:25:48.859064666 +0000
-+++ offscreen/js/ctypes/libffi/configure.ac 2010-02-01 14:26:54.097792073 +0000
+--- offscreen.orig/js/ctypes/libffi/configure.ac 2010-02-02 19:53:16.753906134 +0000
++++ offscreen/js/ctypes/libffi/configure.ac 2010-02-02 19:53:21.895155509 +0000
@@ -17,10 +17,10 @@
# the wrong, non-multilib-adjusted value will be used in multilibs.
# As a side effect, we have to subst CFLAGS ourselves.
Index: offscreen/modules/libpr0n/build/Makefile.in
===================================================================
---- offscreen.orig/modules/libpr0n/build/Makefile.in 2010-01-14 12:06:49.000000000 +0000
-+++ offscreen/modules/libpr0n/build/Makefile.in 2010-02-02 16:58:01.177764887 +0000
+--- offscreen.orig/modules/libpr0n/build/Makefile.in 2010-02-02 19:53:16.783906873 +0000
++++ offscreen/modules/libpr0n/build/Makefile.in 2010-02-02 19:53:21.895155509 +0000
@@ -92,6 +92,7 @@
export::
$(foreach d,$(filter-out icon,$(MOZ_IMG_DECODERS)), \
echo "#define IMG_BUILD_DECODER_${d}";) \
$(foreach d,$(MOZ_IMG_ENCODERS), \
+Index: offscreen/configure.in
+===================================================================
+--- offscreen.orig/configure.in 2010-02-02 19:53:28.493904163 +0000
++++ offscreen/configure.in 2010-02-02 16:33:09.000000000 +0000
+@@ -3250,11 +3250,7 @@
+ dnl ========================================================
+ AC_CHECK_LIB(Xext, XShmCreateImage, _HAVE_XSHM_XEXT=1,,
+ $XLIBS $XEXT_LIBS)
+- AC_CHECK_HEADER(X11/extensions/XShm.h)
+- if test "$ac_cv_header_X11_extensions_XShm_h" = "yes" &&
+- test -n "$_HAVE_XSHM_XEXT"; then
+- AC_DEFINE(HAVE_XSHM)
+- fi
++ AC_DEFINE(HAVE_XSHM)
+
+ dnl ========================================================
+ dnl = Check for XIE
+@@ -8120,15 +8116,7 @@
+ fi # COMPILE_ENVIRONMENT
+
+ if test "$USE_FC_FREETYPE"; then
+- if test "$COMPILE_ENVIRONMENT"; then
+- _SAVE_CPPFLAGS="$CPPFLAGS"
+- CPPFLAGS="$CPPFLAGS $FT2_CFLAGS"
+- AC_CHECK_HEADERS(fontconfig/fcfreetype.h, ,
+- [AC_MSG_ERROR(Can't find header fontconfig/fcfreetype.h.)])
+- CPPFLAGS="$_SAVE_CPPFLAGS"
+- else
+ AC_DEFINE(HAVE_FONTCONFIG_FCFREETYPE_H)
+- fi
+ fi
+
+ dnl Set various defines and substitutions