]> code.ossystems Code Review - openembedded-core.git/commitdiff
libnsl2: Include stdint.h
authorKhem Raj <raj.khem@gmail.com>
Mon, 12 Jun 2017 14:59:04 +0000 (07:59 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 13 Jun 2017 09:46:30 +0000 (10:46 +0100)
uintptr_t is defined in stdint.h

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/libnsl/libnsl2/0001-nis_call.c-Include-stdint.h-for-uintptr_t-definition.patch [new file with mode: 0644]
meta/recipes-extended/libnsl/libnsl2_git.bb

diff --git a/meta/recipes-extended/libnsl/libnsl2/0001-nis_call.c-Include-stdint.h-for-uintptr_t-definition.patch b/meta/recipes-extended/libnsl/libnsl2/0001-nis_call.c-Include-stdint.h-for-uintptr_t-definition.patch
new file mode 100644 (file)
index 0000000..e9ae517
--- /dev/null
@@ -0,0 +1,27 @@
+From d71cbeb3b76e54778a4d5eec6d387cce653537ca Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 9 Jun 2017 09:49:35 -0700
+Subject: [PATCH] nis_call.c: Include stdint.h for uintptr_t definition
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Pending
+
+ src/nisplus/nis_call.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/nisplus/nis_call.c b/src/nisplus/nis_call.c
+index 1a2b90c..1dc982d 100644
+--- a/src/nisplus/nis_call.c
++++ b/src/nisplus/nis_call.c
+@@ -23,6 +23,7 @@
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <string.h>
++#include <stdint.h>
+ #include <libintl.h>
+ #include <rpc/rpc.h>
+ #include <rpc/auth.h>
+-- 
+2.13.1
+
index 1698f69edb7d304190e5a351cbd0f871310e3132..18e37a1ac9bc48aafccd5ccbc6d99380a305e2df 100644 (file)
@@ -18,6 +18,7 @@ SRCREV = "dfa2f313524aff9243c4d8ce1bace73786478356"
 SRC_URI = "git://github.com/thkukuk/libnsl \
            file://0001-include-sys-cdefs.h-explicitly.patch \
            file://0002-Define-glibc-specific-macros.patch \
+           file://0001-nis_call.c-Include-stdint.h-for-uintptr_t-definition.patch \
           "
 
 S = "${WORKDIR}/git"