]> code.ossystems Code Review - openembedded-core.git/commitdiff
glslang/spirv: synchronize with the rest of vulkan items
authorAlexander Kanavin <alex.kanavin@gmail.com>
Thu, 3 Mar 2022 10:13:15 +0000 (11:13 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 4 Mar 2022 17:13:10 +0000 (17:13 +0000)
These components are now versioned in sync with vulkan releases:
https://github.com/KhronosGroup/SPIRV-Headers/issues/252
https://github.com/KhronosGroup/SPIRV-Headers/issues/266

"We'll continue tagging the repos contributing with SDK releases, as
that is when all the testing of the various projects is performed
together."

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/glslang/glslang_1.3.204.0.bb [moved from meta/recipes-graphics/glslang/glslang_11.8.0.bb with 90% similarity]
meta/recipes-graphics/spir/spirv-headers_1.3.204.0.bb [moved from meta/recipes-graphics/spir/spirv-headers_1.5.4.bb with 88% similarity]
meta/recipes-graphics/spir/spirv-tools_1.3.204.0.bb [moved from meta/recipes-graphics/spir/spirv-tools_2022.1.bb with 89% similarity]

similarity index 90%
rename from meta/recipes-graphics/glslang/glslang_11.8.0.bb
rename to meta/recipes-graphics/glslang/glslang_1.3.204.0.bb
index a77d8bdf8819ef176217c2e871ddfbb3d25c93ff..2af406212fe4d0b7d74cc49d53e4d1189a5e5262 100644 (file)
@@ -8,10 +8,11 @@ HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler"
 LICENSE = "BSD-3-Clause & BSD-2-Clause & MIT & Apache-2.0 & GPL-3-with-bison-exception"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2a2b5acd7bc4844964cfda45fe807dc3"
 
-SRCREV = "c34bb3b6c55f6ab084124ad964be95a699700d34"
+SRCREV = "2742e959347ae2fac58acd0d022c92a0ff1f24bf"
 SRC_URI = "git://github.com/KhronosGroup/glslang.git;protocol=https;branch=master \
            file://0001-generate-glslang-pkg-config.patch"
-UPSTREAM_CHECK_GITTAGREGEX = "^(?P<pver>\d+(\.\d+)+)$"
+PE = "1"
+UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
 S = "${WORKDIR}/git"
 
 inherit cmake python3native
similarity index 88%
rename from meta/recipes-graphics/spir/spirv-headers_1.5.4.bb
rename to meta/recipes-graphics/spir/spirv-headers_1.3.204.0.bb
index 3144b1eb429351e99b47389bc87dcd90c8b016bf..72416b441fcad4d289e87ea201bf28448200dfa5 100644 (file)
@@ -9,9 +9,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c938b85bceb8fb26c1a807f28a52ae2d"
 
 SRCREV = "b42ba6d92faf6b4938e6f22ddd186dbdacc98d78"
 SRC_URI = "git://github.com/KhronosGroup/SPIRV-Headers;protocol=https;branch=master"
-UPSTREAM_CHECK_GITTAGREGEX = "^(?P<pver>\d+(\.\d+)+)$"
+PE = "1"
+UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
 S = "${WORKDIR}/git"
-PV .= "+git${SRCPV}"
 
 inherit cmake
 
similarity index 89%
rename from meta/recipes-graphics/spir/spirv-tools_2022.1.bb
rename to meta/recipes-graphics/spir/spirv-tools_1.3.204.0.bb
index 24142a4fe0c41dd61e2b9d1f003ed5473cc04197..dc780737173beb07814aeaaf04836e94a7d6563d 100644 (file)
@@ -7,9 +7,10 @@ SECTION = "graphics"
 LICENSE  = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
-SRCREV = "b1877de5cd776117050bd42f08d04b52bce16099"
-SRC_URI = "git://github.com/KhronosGroup/SPIRV-Tools.git;branch=master;protocol=https"
-UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>\d+(\.\d+)+)$"
+SRCREV = "45dd184c790d6bfc78a5a74a10c37e888b1823fa"
+SRC_URI = "git://github.com/KhronosGroup/SPIRV-Tools.git;branch=stable;protocol=https"
+PE = "1"
+UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
 S = "${WORKDIR}/git"
 
 inherit cmake python3native